Bug 706889 - “-1” displayed on console while unsubscribe invalid serial
“-1” displayed on console while unsubscribe invalid serial
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Devan Goodwin
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-23 07:32 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description spandey 2011-05-23 07:32:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
5/5

Prerequisites :
Client : Rhel5.7 with following subscription manager client 
subscription-manager-firstboot-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-gnome-0.95.5.18-1.git.4.364aa10.el5

Steps to Reproduce : 

Execute following command on console 
[root@dhcp201-172 ~]# subscription-manager unsubscribe --serial lkjskshs

Expected Result : 
Proper Message should display on console for invalid serial number 

Actual Result : 
 
[root@dhcp201-172 ~]# subscription-manager unsubscribe --serial lkjskshs --proxy 10.65.193.99:3128

'lkjskshs' is not a valid serial number

-1
Comment 1 Chris Duryee 2011-05-23 10:11:15 EDT
Moving to 6.2 since that's the next tracker and the bug needs to be fixed in the master branch, but this bug will only manifest on el5 (just fyi for developers).
Comment 3 Devan Goodwin 2011-07-21 10:50:32 EDT
Fix in subscription-manager.git master branch: cfbd5a361a8fd4210e8fb27fc9b317e8f547ee25

handle_exception method now checks if we're looking at a SystemExit exception, and if so skips all the processing / printing of the exception message. (as this is a pretty clear indication we already did some error handling and called sys.exit)
Comment 4 Shwetha Kallesh 2011-07-26 06:41:04 EDT
Moving the bug to verified as it result is as expected

RPM used :

subscription-manager-0.96.4-1.git.62.75efb0a.el6.x86_64
subscription-manager-firstboot-0.96.4-1.git.62.75efb0a.el6.x86_64
subscription-manager-gnome-0.96.4-1.git.62.75efb0a.el6.x86_64

Steps to reproduce :

subscription-manager unsubscribe --serial lkjskshs

Output:

'lkjskshs' is not a valid serial number
Comment 5 Shwetha Kallesh 2011-07-26 06:42:12 EDT
Unable to change the status...Pls change the status to verified
Comment 6 errata-xmlrpc 2011-12-06 12:14:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.