Bug 706979 - config file permissions are world readable
config file permissions are world readable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
: EasyFix
Depends On:
Blocks: 782183 960054
  Show dependency treegraph
 
Reported: 2011-05-23 12:48 EDT by Steve Grubb
Modified: 2015-09-27 22:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: cronie-1.4.4-9.el6
Doc Type: Bug Fix
Doc Text:
Cause: File permissions on configuration file weren't too strict. Consequence: Every user can read many configuration files of cron. Fix: File permissions were changed. Result: Only root can read the configuration files.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 17:22:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 42603 None None None 2012-09-27 07:24:14 EDT

  None (edit)
Description Steve Grubb 2011-05-23 12:48:37 EDT
Description of problem:
The DISA STIG calls out for cron config files to be 0600 or more restrictive:
http://people.redhat.com/sgrubb/files/stig-2011/stig-2011-checklist.html#item-SV-978r7_rule
Currently there are files that have 0644 permissions. We need to align the permissions to match the STIG so there is less to lockdown out of the box.
Comment 1 Marcela Mašláňová 2011-05-24 04:51:22 EDT
I can't be responsible for scripts in cron directories /etc/crond.*, because there are created by other applications or users. They are executable on purpose in some cases.

Also please note -p option, which is used for crontabs in /var/spool/cron directory. Crontabs there should be according to your policy.
<cite>
crontab files have to be regular files or symlinks to regular files, they must not be executable or writable for anyone else but the owner. This requirement  can  be overridden by using the -p option on the crond command line. If inotify support is in use, changes in the symlinked crontabs are not automatically noticed by the cron daemon.
</cite>

Config files can be changed to 600 if they have higher permission.
Comment 25 Steve Grubb 2013-09-29 13:20:36 EDT
There is a script here that can be used for testing:
http://people.redhat.com/sgrubb/files/stig-2011/stig-file-test.sh
Comment 28 errata-xmlrpc 2013-11-21 17:22:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1681.html

Note You need to log in before you can comment on or make changes to this bug.