Bug 70701 - gnome-terminal not clearing screen in lynx when it should do a blank line.
gnome-terminal not clearing screen in lynx when it should do a blank line.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
http://www.linux.org.uk/~telsa/BitsAn...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-04 06:55 EDT by Telsa Gwynne
Modified: 2015-01-07 18:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-04 06:55:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-08-04 06:55:10 EDT
Description of Problem:

With a standard 80x25 terminal, lynx to a particular file shows portions
of the earlier part of the file when it shouldn't.

Version-Release number of selected component (if applicable):

gnome-core-1.4.0.4-54 and lynx-2.8.4-18.

How Reproducible:

Seems to be reasonably so.

Steps to Reproduce:
1. You may need my lynx config for this: I have the 'advanced' mode.
(this is just to make sure the status line is the same size as mine)
2. start a normal-sized (80x25) gnome-terminal.
3. lynx http://www.linux.org.uk/~telsa/BitsAndPieces/muttrc-1.2
4: You will be on "(p1 of 35)" (top right hand of corner)
5. Page down using the space bar until you get to page 25, where you
will see a line about COLORFGBG="default;default".
6. Page down using space bar again. You will (I hope!) see:

Actual results:
# give you some ideas.                                         #
#              	COLORFGBG="default;default"                    #
# Some basics:                                                 #

This should not be there. That should be a blank line. Paging
down again to p 27 of 35 shows the same variable cropping up.

Trying to select-by-line and paste those three lines to here, I
found the COLORFGBG line had vanished. 

Scrolling down again to p 28 and back up removes the spurious
line too.

Expected Results:

COLORFGBG line should appear only once, and not keep cropping up
on otherwise blank lines. 

Additional Information:

I strongly suspect the line that keeps appearing is actually
completely wrong, so please don't feel the need to tell me that :)

I have seen other gnome-terminal/lynx weirdnesses before: with a
specific size of gnome-terminal I can get the advanced search on
google to show only the top half of the page and lose all the rest.
See bug #59166 for that. Dunno whether related?
Comment 1 Havoc Pennington 2002-08-04 11:51:20 EDT
We aren't going to be able to fix the 2000 terminal emulation bugs in libzvt for
gnome 1.4 at this point.

Note You need to log in before you can comment on or make changes to this bug.