This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 707027 - RFE: Installation on Z/VM EDEV failed during format
RFE: Installation on Z/VM EDEV failed during format
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 707026
Blocks: 606814 647893 705163 708145
  Show dependency treegraph
 
Reported: 2011-05-23 15:30 EDT by David Cantrell
Modified: 2014-03-19 08:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: parted-3.1-8.fc18
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 606814
Environment:
Last Closed: 2012-12-20 10:26:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
parted-3.1-libparted-add-support-for-implicit-FBA-DASD-partitions.patch (5.95 KB, text/plain)
2012-09-25 10:21 EDT, IBM Bug Proxy
no flags Details
parted-3.1-libparted-mklabel-edev.patch (1.46 KB, text/plain)
2012-12-07 06:02 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 84317 None None None 2012-08-15 12:08:35 EDT

  None (edit)
Comment 1 Georg Markgraf 2012-09-21 09:33:21 EDT
The plan is (IBM) to post the patch (in the week of 9-24) to Fedora for discussion, when discussions complete Red Hat should post the patch for R 6.4
using the R 6.4 bugzilla 
 65219 - RH606814- Installation on Z/VM EDEV failed during format

Please request BZ 606814 as a blocker for R 6.4 (mentioned in bug call and Fedora call) to ensure it makes 6.4 when Fedora discussions are done
Comment 2 IBM Bug Proxy 2012-09-25 10:21:57 EDT
Created attachment 617070 [details]
parted-3.1-libparted-add-support-for-implicit-FBA-DASD-partitions.patch
Comment 3 Dan Horák 2012-09-25 11:19:16 EDT
(In reply to comment #2)
> Created attachment 617070 [details]
> parted-3.1-libparted-add-support-for-implicit-FBA-DASD-partitions.patch

IBM, what's the upstream status of the attached patch?
Comment 4 IBM Bug Proxy 2012-10-09 11:51:14 EDT
Hi Dan,

(In reply to comment #5)
> (In reply to comment #2)
> > Created attachment 617070 [details]
> > parted-3.1-libparted-add-support-for-implicit-FBA-DASD-partitions.patch
>
> IBM, what's the upstream status of the attached patch?

The patches have been posted upstream:

http://lists.gnu.org/archive/html/bug-parted/2012-10/msg00013.html
Comment 5 Fedora Update System 2012-10-16 20:12:25 EDT
parted-3.1-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/parted-3.1-8.fc18
Comment 6 Fedora Update System 2012-10-16 23:18:31 EDT
Package parted-3.1-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-3.1-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16288/parted-3.1-8.fc18
then log in and leave karma (feedback).
Comment 7 IBM Bug Proxy 2012-10-29 17:20:36 EDT
Hello Red Hat,
The fix in parted got tested on fedora 18  - the parted fix seem to work (final confirmation to come)

But there is a problem in installer

Could be that the installer tries to low level format any emulated DASD it recognizes and with that makes the fix in parted unusable for the distribution ..
the installer fix cannot be integrated into RHEL 6.4 .. per our discussion...

So your plan is to send an updated ISO including the parted fix and the installer fix.  include parted in R 6.4 and later include the installer fix for RHEL 6.5
-> Is that still correct?
-> Do you have the installer fix already available?
Comment 8 IBM Bug Proxy 2012-11-07 08:41:42 EST
For the record:
Based on tests performed at IBM
Testing EDEV support in parted
on Fedora 18
-> Identified installer problem - (installer changes on F18)
-> additional fix for parted in work at IBM
on RHEL 6.3
-> NO installer problems identified
-> the EDEV support in parted works without problems
the related R 6.3 BZ is
65219 - RH606814- Installation on Z/VM EDEV failed during format

Therefore the EDEV support can be included for R 6.4 without the requirement for installer fixes to be implemented with RHEL 6.5
Comment 9 IBM Bug Proxy 2012-12-07 06:02:21 EST
Created attachment 659300 [details]
parted-3.1-libparted-mklabel-edev.patch





1. What is the problem?
Installation will fail with 'fresh/zeroing EDEV DASD'. Because 'mklabel' code path does not know how to handle 'EDEV DASD'.

2. When this problem occurs
Problem triggers with installation on 'fresh/zeroing EDEV DASD'

3. The attached patch fixes the above problem by reading/assigning correct meta-data to the EDEV DASD with 'mklabel' code path.

4. Test results
With this patch - installs successfully on 'fresh/zeroing EDEV DASD'

With out this patch - installation fails with the following error
"BUG: specified free space extent for deleting doesn't match free space currently shown in FMT7 DSCB!"


Please find the order of applying the patches.

1. parted-3.1-libparted-add-support-for-implicit-FBA-DASD-partitions.patch 
And the following (2, 3) two patches attached to "RH707032- Installation on EAV DASD failed"
2. parted-3.1-libparted-add-support-for-EAV-DASD-partitions.patch
3. parted-3.1-libparted-mklabel-eav.patch
4. parted-3.1-libparted-mklabel-edev.patch
Comment 10 Fedora Update System 2012-12-20 10:26:37 EST
parted-3.1-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 IBM Bug Proxy 2014-03-19 08:10:15 EDT
This has been tested last year on fedora and R 7 alpha - also F18 is out of service
Closing BZ .. thx

Note You need to log in before you can comment on or make changes to this bug.