This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 707034 - [6.1 FEAT] Intuitive dump device configuration workflow and dialogue
[6.1 FEAT] Intuitive dump device configuration workflow and dialogue
Status: CLOSED DUPLICATE of bug 745495
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
s390x All
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 638197 633398 705163
  Show dependency treegraph
 
Reported: 2011-05-23 15:39 EDT by David Cantrell
Modified: 2012-06-27 09:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 633398
Environment:
Last Closed: 2012-06-27 09:50:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
RHEL 6 dump install description (93.78 KB, application/x-pdf)
2011-09-07 08:13 EDT, Georg Markgraf
no flags Details
perl sample script for DASD (5.93 KB, text/plain)
2011-09-07 08:15 EDT, Georg Markgraf
no flags Details
perl sample script for SCSI (4.96 KB, text/plain)
2011-09-07 08:17 EDT, Georg Markgraf
no flags Details
dump_install_dasd.pl (5.93 KB, application/x-perl)
2011-11-02 16:05 EDT, IBM Bug Proxy
no flags Details
dump_install_scsi.pl (5.13 KB, application/x-perl)
2011-11-02 16:05 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Comment 1 Georg Markgraf 2011-09-07 08:13:19 EDT
Created attachment 521855 [details]
RHEL 6 dump install description
Comment 2 Georg Markgraf 2011-09-07 08:15:58 EDT
Created attachment 521856 [details]
perl sample script for DASD
Comment 3 Georg Markgraf 2011-09-07 08:17:54 EDT
Created attachment 521857 [details]
perl sample script for SCSI
Comment 4 Brad Hinson 2011-10-17 15:09:24 EDT
Hi Georg,

On x86 the dump configuration (kdump) is done in firstboot, which happens after install and the first time the system comes up.  Now that we have firstboot working on z, to be more consistent, we should add the z dump configuration in firstboot instead of anaconda.  What do you think?

-Brad
Comment 5 Georg Markgraf 2011-10-28 11:13:50 EDT
Hi Brad,
Yes first boot would also be ok instead of anaconda
Just a simple to handle user interface for setting up the dump devices  

Site note: 
Good news -new to me- that first boot is functional again for System z
Its been rejected for years throughout RHEL 5
Comment 6 IBM Bug Proxy 2011-11-02 16:05:27 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 11:24 EDT-------
Code Upstream Status: Pending

------- Comment From mgrf@de.ibm.com 2010-12-13 12:15 EDT-------
Accept reject for R 6.1 - will request this for R 6.2 again

------- Comment From mgrf@de.ibm.com 2011-08-24 15:37 EDT-------
Per discussion with John
I assign this feature to the RHEL 6.3 tracking list
This also get discussed in Fedora via ticket 707034

The process of mirroring from/to Fedora is actually in discussion
1) assign this feature BZ to the Fedora ticket
when Fedora is resolved re-assign to R 6.3
2) create reverse mirror of the Fedora ticket and have parallel tracking
Comment 7 IBM Bug Proxy 2011-11-02 16:05:40 EDT
Created attachment 531440 [details]
dump_install_dasd.pl


------- Comment on attachment From michael.holzheu@de.ibm.com 2011-09-13 08:48 EDT-------


Update for RHEL6
Comment 8 IBM Bug Proxy 2011-11-02 16:05:53 EDT
Created attachment 531441 [details]
dump_install_scsi.pl


------- Comment on attachment From michael.holzheu@de.ibm.com 2011-09-13 08:49 EDT-------


Update for RHEL6
Comment 9 Georg Markgraf 2011-11-16 11:23:14 EST
As discussed I re-call

 + Yes setting up dump devices in first boot would also be ok
 + just a simple to handle user interface for setting up the dump devices

 -> Setting this up in first boot would avoid any changes in installer ?
Comment 10 IBM Bug Proxy 2012-06-07 02:50:53 EDT
------- Comment From mgrf@de.ibm.com 2012-06-07 06:48 EDT-------
This feature got implemented into R 6.3 via
74353 - RH 745495  [6.3 FEAT] Two Stage Dumper framework - installer

This feature is verified on R 6.3 snapshots -> set to verified on IBM site
Comment 11 John Jarvis 2012-06-27 09:50:21 EDT

*** This bug has been marked as a duplicate of bug 745495 ***

Note You need to log in before you can comment on or make changes to this bug.