Bug 707115 - cluster rebase
Summary: cluster rebase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Cluster QE
URL:
Whiteboard: Rebase
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-24 06:48 UTC by Fabio Massimo Di Nitto
Modified: 2011-12-06 14:52 UTC (History)
7 users (show)

Fixed In Version: cluster-3.0.12.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
This update fixes a few bugs, and will make future updates easier.
Clone Of:
Environment:
Last Closed: 2011-12-06 14:52:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1516 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-12-06 00:51:09 UTC

Description Fabio Massimo Di Nitto 2011-05-24 06:48:21 UTC
Initial evaluation shows that we can rebase safely based on a new tarball released from the RHEL6 branch.

Pros:

1) drop lots of unrequired code from cluster tarball (fence-agents, resource-agents, gfs and gfs-kernel)
2) kill patch queue from distcvs
3) simplify build / spec file

Verification process:

from distcvs RHEL6 branch in current release:

sed -i -e 's#\-b .*##g' cluster.spec
make prep

this would apply all patches to current 3.0.12 tree without extensions
(makes it easier to parse the diff)

replace 3.0.12 tarball with 3.0.12.1 tarball created from current git
RHEL6 branch (we cannot move to 3.1.x for several other reasons).

diff -Naurd cluster-3.0.12 cluster-3.0.12.1 | filterdiff -x '*.orig' -x
'*rgmanager*' -x '*fence/agents*'  | less

The only change that will be pulled in is:

config/tools/xml/cluster.rng.in: schema description updates, no
functional changes. There is no BZ associated to this change, but it is
purely cosmetic.

Changes to the build systems are necessary to drop fas, ras, gfs and gfs-kernel. No other changes will be introduced.

Comment 2 Fabio Massimo Di Nitto 2011-05-26 13:28:09 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This update fixes a few bugs, and will make future updates easier.

Comment 3 Fabio Massimo Di Nitto 2011-06-15 06:25:06 UTC
Unit test results:

> The only change that will be pulled in is:
> 
> config/tools/xml/cluster.rng.in: schema description updates, no
> functional changes. There is no BZ associated to this change, but it is
> purely cosmetic.

[root@rhel6-node2 ~]# rpm -q -f /usr/sbin/ccs_config_validate 
cman-3.0.12.1-2.el6.x86_64
[root@rhel6-node2 ~]# ccs_config_validate 
Configuration validates

the changes to the schema do not introduce regression. schema still works as expected (without going into extreme paranoia, cluster.conf validated before and after the upgrade).

> Changes to the build systems are necessary to drop fas, ras, gfs and
> gfs-kernel. No other changes will be introduced.

Package has built in brew, changes to the build system appear sane. Code has been dropped as mentioned.

Comment 7 errata-xmlrpc 2011-12-06 14:52:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1516.html


Note You need to log in before you can comment on or make changes to this bug.