Bug 707172 - missing pxelinux.0 in /var/lib/tftpboot, PXE does not work
missing pxelinux.0 in /var/lib/tftpboot, PXE does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
541
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Lukas Pramuk
:
Depends On:
Blocks: sat560-provisioning
  Show dependency treegraph
 
Reported: 2011-05-24 06:10 EDT by Petr Sklenar
Modified: 2013-10-01 17:40 EDT (History)
5 users (show)

See Also:
Fixed In Version: cobbler-loaders-1.0.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2011-05-24 06:10:49 EDT
Description of problem:
I cannot use provisioning over the PXE.

Version-Release number of selected component (if applicable):
Satellite-5.4.1-RHEL6-re20110511.0
cobbler-2.0.7-8.el6sat.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. set up network up to satellite's doc
2. cobbler sync
  
Actual results:
ll /var/lib/tftpboot
total 20
drwxr-xr-x. 2 root root 4096 May 16 10:11 etc
drwxr-xr-x. 4 root root 4096 May 24 05:10 images
drwxr-xr-x. 2 root root 4096 May 16 10:11 ppc
drwxr-xr-x. 2 root root 4096 May 24 05:10 pxelinux.cfg
drwxr-xr-x. 2 root root 4096 May 24 05:10 s390x


Expected results:
there are missing files (pxelinux.0 and more) in /var/lib/tftpboot

Additional info:
workaround:
cobbler get-loaders
# which downloads needed files from http://mdehaan.fedorapeople.org/loaders into /var/lib/tftpboot
Comment 11 Clifford Perry 2013-10-01 17:40:27 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.