Bug 707252 - [RFE]Allow any registered user to change the Blocks: field
[RFE]Allow any registered user to change the Blocks: field
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
: FutureFeature
: 758510 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-24 09:59 EDT by Adam Williamson
Modified: 2013-06-23 23:38 EDT (History)
12 users (show)

See Also:
Fixed In Version: 4.2.5-8
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 18:13:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-05-24 09:59:17 EDT
As requested by Bugzilla admin team, filing a public bug for this. We (QA) would like to ask that the Bugzilla configuration be adjusted such that any registered user can change the Blocks: field of a Fedora bug. This is necessary to the smooth functioning of the blocker bug process:

https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process

as the mechanism by which you propose a bug as a release blocker is to set it as blocking another bug.
Comment 1 Adam Williamson 2011-05-24 09:59:59 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2011-11-29 20:04:01 EST
*** Bug 758510 has been marked as a duplicate of this bug. ***
Comment 4 Simon Green 2012-06-20 20:49:10 EDT
This would also allow the Depends On field to be changed, as blocking one bug automatically creates a depends on link the other way.
Comment 5 Till Maas 2012-06-29 18:38:05 EDT
According to http://www.bugzilla.org/docs/tip/en/html/products.html#product-group-controls
it seems to be possible to create a group editbugs group for Fedora such as editbugs_fedora that allows their members to only edit all bug fields in bugs in the Fedora product.
Comment 6 Adam Williamson 2012-06-29 18:42:41 EDT
That's not what we want, though. We don't want everyone to be able to edit *any field* in Fedora bugs. We want everyone (registered) to be able to edit a single specific field in Fedora bugs.
Comment 7 Till Maas 2012-06-29 19:00:34 EDT
(In reply to comment #6)
> That's not what we want, though. We don't want everyone to be able to edit
> *any field* in Fedora bugs. We want everyone (registered) to be able to edit
> a single specific field in Fedora bugs.

Then it seems to be that the code needs to be modified:
http://www.bugzilla.org/docs/4.2/en/html/cust-change-permissions.html
Comment 9 Matt Tyson 2012-11-27 20:34:44 EST
I've updated the code so that any registered bugzilla user can edit the blocks and dependson field for the Fedora product, without requiring any special permissions.
Comment 11 Adam Williamson 2012-11-28 04:41:38 EST
Matt: you are my new favourite person and I owe you many, many beers. thanks!
Comment 12 Matt Tyson 2012-12-05 23:05:51 EST
I've changed this to remove the ability to edit the 'depends on' field.
Now registered users will only be able to edit the Blocks: field.
Comment 14 Chen Chen 2013-02-19 02:19:33 EST
Verified on version 4.4-1 on test sever --> PASS

Verify steps:
1. Log in bugzilla with public@test.com account.
2. Search a fedora public bug bug A.
3. Change the blocks field with another fedora public bug B.
4. Go to bug B's detail page, check depends on field.
5. Search a Bugzilla public bug bug C.
6. Change the blocks field with another public Bugzilla bug bug D.
7. Go to bug D's detail page, check depends on field.
8. Go to bug A's detail page, update depends on field.
9. Go to bug C's detail page, update depends on field.

Actual result:
1. After step3, blocks field of bug A can be changed successfully.
2. After step4, bug B's depends on field is changed.
3. After step6, blocks field of bug C cannot be changed.
4. After step7, bug D's depends on field not be changed.
5. After step8, bug A's depends on field can not be updated.
6. After step9, bug C's depends on field can not be updated.
Comment 15 Jin Zhao 2013-02-26 20:49:37 EST
Change to ON_QA in order to verify again on v4.2-8
Comment 18 Simon Green 2013-03-14 18:13:19 EDT
This change is now live.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.