Bug 707481 - Kernel image prepared by preupgrade freezes after "Trying to unpack rootfs image" message appears on console
Kernel image prepared by preupgrade freezes after "Trying to unpack rootfs im...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
15
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-25 04:30 EDT by Chris Rankin
Modified: 2013-01-15 09:18 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 14:11:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Rankin 2011-05-25 04:30:55 EDT
Description of problem:
I ran preupgrade to upgrade a test box from F14 to F15. preupgrade completed successfully, but the "Upgrade to Fedora 15" kernel hangs forever at the message:

Trying to unpack rootfs image as initramfs...

Version-Release number of selected component (if applicable):
preupgrade-1.1.9-1.fc14.noarch

How reproducible:
All the time.

Steps to Reproduce:
1. Run preupgrade
2. Reboot
3. Wait forever
  
Actual results:
The "upgrade" never happens.

Expected results:
The box would be upgraded to F15.

Additional info:
Comment 1 Chris Rankin 2011-05-26 16:02:37 EDT
The boot freezes before switching to KMS. However, I have KMS enabled just fine under Fedora 14 with a stock 2.6.38.7 kernel. (This is a Radeon 9200, rv280 chip.)
Comment 2 Chris Rankin 2011-05-27 04:06:54 EDT
This particular PC has only 512MB of RAM - which should be enough, according to the system requirements. (I also have one Fedora 14 PC with only 384 MB of RAM...) However, I am starting to suspect that this isn't enough, given that someone has already raised bug #682555.

My best bet might be to remove all of the kernel modules that I know I won't need from initrd.img, except that I cannot find a System.map file for the installer's vmlinuz. I think I'll need that in order to regenerate all the module dependencies.

Any help, please?
Comment 3 Matthieu Araman 2011-05-29 05:08:46 EDT
hello,


same pb here, same preupgrade version, trying to upgrade to fc15 from fc14
also 512M of ram
Trying to unpack rootfs image as initramfs...
then nothing happens

I can revert to fc14 at reboot via grub and replicate the problem each time I manually select the upgrade entry.

smolt profile : http://www.smolts.org/client/show/pub_9ed33a07-dcc5-42a8-9689-8826fe44e846
Comment 4 Han Boetes 2011-06-06 07:19:19 EDT
I tried installing fc15 in a virtual machine with 512MB memory and it failed. After that I tried it with 1024MB and it did work. Case made: 512Mb does not suffice.
Comment 5 Stian Oksavik 2011-06-08 10:21:32 EDT
I am experiencing the same thing. Install in a VM with 512MB RAM freezes forever at "Trying to unpack rootfs image as initramfs". Increasing the RAM allocation to 1024MB resolves the problem.

I have not tried experimenting with RAM amounts to see if e.g. 640MB is sufficient. However, it seems clear that either the rootfs image needs to shrink or Fedora's published minimum RAM requirement needs to grow.
Comment 6 G. Michael Carter 2011-06-09 18:49:59 EDT
I'm trying with a PXE install and I'm getting the same thing.  512MB of ram on the machine.
Comment 7 Chris Rankin 2011-06-11 20:09:27 EDT
I have recreated the initramfs.img file with the following changes:

- deleting all unnecessary firmware
- deleting the empty directory structure for kernel modules under /lib/modules
- deleting all .mo files

This reduces the image by about 20%, and allows the kernel to boot.

Unfortunately, it now boots to a text-mode screen saying that the installer wants 640MB of RAM, and that I only have 512MB!
Comment 8 Richard Hughes 2011-06-17 03:55:05 EDT
I think it's probably an idea to make preupgrade check for sufficient memory (1024Mb) before allowing the user to start. I think the initramfs is only going to get bigger in future releases.

Comments?
Comment 9 Chris Rankin 2011-06-17 04:00:38 EDT
That would be a good idea: preupgrade knew that the PC had only 512 MB of RAM, so why bother preparing an upgrade that then demands 640 MB of RAM?

Having said that, there's something intrinsically *wrong* with an upgrade procedure that needs 1024 MB to install an OS that only needs 384 MB to run.

Your installer is a fat pig.
Comment 10 Chris Rankin 2011-06-17 04:26:53 EDT
As an aside, the only firmware file that the installer would have needed to find inside the initramfs was R200.bin, and preupgrade could have worked this out too. The incredible amount of other firmware I discovered in there was just irrelevant memory-hogging bloat.

So here's a thought: preupgrade should be *smarter*, and create an initramfs that is tailored for the hardware that it is running on.
Comment 11 bob mckay 2011-06-20 05:49:14 EDT
Please pardon any misunderstanding, but is this the same problem as Bug 708966? If so, would a solution be to backstitch the modifications in the F15 anaconda into F14 preupgrade?
Comment 12 David Ford 2011-09-29 19:23:59 EDT
I have the same problem ( 512M ram - hangs at "Trying to "etc) with the Network Install CD.

No help from pre-upgrade here!

Surely there must be a way to reduce the size of the installer?
Comment 13 David Parkin 2011-10-02 10:30:21 EDT
Same problem low RAM 512M same message.
Comment 14 Michael Dale Long 2011-12-05 20:10:06 EST
Same problem on a VM with 512MB.  Upping to 1GB got past this issue.
Comment 15 Fedora End Of Life 2012-08-07 14:11:34 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.