Bug 707525 - Facts update command displays consumed uuid
Facts update command displays consumed uuid
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-25 06:21 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: master
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description spandey 2011-05-25 06:21:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Prerequisites : 
Client : Rhel5.7 client (RHEL5.7-Server-20110518.0 beta build)
Server : subscription.rhn.stage.redhat.com

Steps to repro : 

1) Register client to candlepin
2) Execute command for facts update 

Expected Result : 
Command should successfully executed and proper message should display on console 
like “facts sucessfully updated “

Actual Result : 
Consumed uuid displayed on console .

[root@ibm-z10-26 ~]# subscription-manager identity
Current identity is: 254fc030-9f62-4170-ba12-4423cc246a00 name: ibm-z10-26.rhts.eng.bos.redhat.com
[root@ibm-z10-26 ~]# subscription-manager facts --update
254fc030-9f62-4170-ba12-4423cc246a00
Comment 2 Michael Stead 2011-06-22 11:14:20 EDT
Now fixed in master.

Commit: ebacf680e7a8fec70d7b4dc091c6432ce3f83775

Now displays 'Facts successfully updated' on success.
Comment 3 Shwetha Kallesh 2011-07-08 03:43:14 EDT
RPM version :

subscription-manager-0.96.2-1.el6.x86_64
subscription-manager-firstboot-0.96.2-1.el6.x86_64
subscription-manager-gnome-0.96.2-1.el6.x86_64


Verified using following steps:

[root@sachbeta ~]# subscription-manager facts --update
Facts sucessfully updated.

Please changed the status to verified as I dont have previlage to change the status..
Comment 4 spandey 2011-07-11 06:38:49 EDT
Verified using following rpm 

[root@dhcp201-165 ~]# rpm -qa | grep subscription-manager
subscription-manager-gnome-0.96.3-1.git.0.723b652.el6.i386
subscription-manager-0.96.3-1.git.0.723b652.el6.i386
subscription-manager-firstboot-0.96.3-1.git.0.723b652.el6.i386
[root@dhcp201-165 ~]# subscription-manager facts --update
Facts sucessfully updated.


Working fine
Comment 5 errata-xmlrpc 2011-12-06 12:14:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.