Bug 707570 - 10. Virtualization mentions rhel5 channels, but not rhel6 channels
10. Virtualization mentions rhel5 channels, but not rhel6 channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On:
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-05-25 08:21 EDT by Šimon Lukašík
Modified: 2013-10-23 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-29 16:09:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2011-05-25 08:21:03 EDT
Description of problem:
At the very beginning of Chapter 10 in the reference guide there is
a list of required channels:

    Red Hat Network Tools for RHEL Server (v. 5 for 32-bit x86)
     — rhn-tools-rhel-i386-server-5
    RHN Tools
     — rhn-tools-rhel-5-i386
    Red Hat Enterprise Linux Server (v. 5 for 32-bit x86)
     — rhel-i386-server-5 (and all child channels)
    Red Hat Enterprise Linux Server Virtualization (v. 5 for 32-bit x86)
     — rhel-i386-server-vt-5 (and all child channels) 

You can see rhel version hard-coded to the documentation, which does
not seem ideal to me. Anyway, for rhel6 there is no such channel 
'Virtualization'. Rhel6 costumer needs to sync at least:

    rhel-i386-server-6
    rhn-tools-rhel-i386-server-6

instead. Please consider, whether we really want to list required
channels. And also consider, whether we should better list x86_64
architecture instead of i386 in the year 2011.


Additional info:
See also bug 707568
Comment 1 Lana Brindley 2011-05-26 17:14:24 EDT
It's too late to get this into 5.4.1 docs, but should we add it to the relnotes? If so, please clone this bug and apply the clone against the release_notes component.

LKB
Comment 2 Šimon Lukašík 2011-05-27 03:34:34 EDT
I think, this is not so important, to be included in the release_notes.
Moreover, this bug also applies to Satellite 5.4.0 documentation, which does
not mention it as well. From my view, this is only nice_to_have in future.
Comment 3 Lana Brindley 2011-06-13 16:14:22 EDT
Slated for 5.4.2.

LKB
Comment 4 Lana Brindley 2011-09-22 16:45:15 EDT
(In reply to comment #0)
> Description of problem:
> At the very beginning of Chapter 10 in the reference guide there is
> a list of required channels:
> 
>     Red Hat Network Tools for RHEL Server (v. 5 for 32-bit x86)
>      — rhn-tools-rhel-i386-server-5
>     RHN Tools
>      — rhn-tools-rhel-5-i386
>     Red Hat Enterprise Linux Server (v. 5 for 32-bit x86)
>      — rhel-i386-server-5 (and all child channels)
>     Red Hat Enterprise Linux Server Virtualization (v. 5 for 32-bit x86)
>      — rhel-i386-server-vt-5 (and all child channels) 
> 
> You can see rhel version hard-coded to the documentation, which does
> not seem ideal to me. Anyway, for rhel6 there is no such channel 
> 'Virtualization'. Rhel6 costumer needs to sync at least:
> 
>     rhel-i386-server-6
>     rhn-tools-rhel-i386-server-6
> 
> instead. Please consider, whether we really want to list required
> channels. And also consider, whether we should better list x86_64
> architecture instead of i386 in the year 2011.
> 
> 
> Additional info:
> See also bug 707568

Hi Šimon,

This is actually not hard-coded into the documentation, it uses entities as follows:

<para>
	Red Hat Network Tools for RHEL Server (v. &RHELVER; for 32-bit x86) &mdash; rhn-tools-rhel-i386-server-&RHELVER;
</para>

Currently, <!ENTITY RHELVER "5"> but I can update this to 6, if you think it is appropriate?

LKB
Comment 5 Šimon Lukašík 2011-09-26 03:19:08 EDT
Well, I am not a documentation person. I am not sure, what is the best
approach here. For example, if we really want to list required channels.

Nevertheless, you should not simply flip &RHELVER to 6, because one
of the rhel-i386-server-vt-5 channel does not exists on RHEL6.

I can see several problems with a current listings:
  (1) It's rhel5 specific, it does not compound any info for rhel6.
  (2) It lists i386 architecture, while it's 21 century.
  (3) It contains vague: '(and all child channels)', which is not true.
  (4) It lists base channels after child channels
Comment 6 Šimon Lukašík 2011-09-26 03:31:57 EDT
The text could read:

-----
The set of recommended channels depends on the platform and architecture
of the host system:

 * for RHEL5, RHN recommends at least the following channels:
    Red Hat Enterprise Linux Server (v. 5 for 32-bit x86) -- rhel-i386-server-5
    Red Hat Network Tools for RHEL Server (v. 5 for 32-bit x86) -- rhn-tools-rhel-i386-server-5
    Red Hat Enterprise Linux Server Virtualization (v. 5 for 32-bit x86) -- rhel-i386-server-vt-5

 * for RHEL6, RHN recommends at least the following channels:
    Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64) -- rhel-x86_64-server-6
    RHN Tools for RHEL (v.6 for 64-bit x86_64) -- rhn-tools-rhel-x86_64-server-6
-----

Note You need to log in before you can comment on or make changes to this bug.