Bug 707591 - Add instruction for rhel6 to the section: 10.1.2.3
Add instruction for rhel6 to the section: 10.1.2.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On:
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-05-25 09:22 EDT by Šimon Lukašík
Modified: 2013-10-23 19:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-29 16:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2011-05-25 09:22:06 EDT
Description of problem:
In the reference guide there is a section named:

    10.1.2.3. Your Host System Has Red Hat Enterprise Linux 5 Installed

Majority of instruction applies to both rhel5 and rhel6. Although
there is a few differences:

 * We do not support xen host on rhel6
 * Required kvm package has a different name on rhel5 and rhel6


Version-Release number of selected component (if applicable):
RHN Satellite 5.4.0 Reference Guide
RHN Satellite 5.4.1 Reference Guide


Additional info:
I would advice to make a separate section for Xen and Kvm.

1) For Xen host, it should be mentioned, that this is option only for
rhel5. The rest of option should remain the same.

2) For Kvm host (which is support on both platforms). I have prepared 
the on rhel5 and rhel6 by a following command:

  yum install python-virtinst /usr/libexec/qemu-kvm /usr/bin/qemu-img

I am not sure, If it's a best option for a documentation, but either way:
kvm package is not on rhel6. On rhel6 there is a qemu-kvm package instead.

Additionally, I have found python-virtinst package as a necessary
perquisite, on both rhel5 and rhel6.

It may also worth the consideration to document essential modprobe
command. (which is needed if user wants to avoid restart described
in a step 5. Note that step 5 does not apply to kvm)
Comment 1 Lana Brindley 2011-06-13 16:14:54 EDT
Slated for 5.4.2.

LKB
Comment 2 Lana Brindley 2011-09-22 16:56:54 EDT
I have made a start here by commenting out the RHEL 4 instructions, and adding in the RHEL 6 instructions (based on the RHEL 5 ones, with xen components removed and a note added about support for xen).

Can you please review the instructions in the revision 2-4 of the 5.4 Reference Guide available on the stage, and advise me of any further changes to these procedures.

Thanks,
LKB
Comment 4 Šimon Lukašík 2011-09-26 04:06:06 EDT
First of all, I don't like the Xen instructions to be removed completely.
We are still supporting Xen Virtualization on RHEL5. Please take them back.

Currently, the instruction on stage at

    10.1.2.2. Your Host System Has Red Hat Enterprise Linux 6 Installed

will not work on rhel6.

What I have meant by this bugzilla is that we may want to describe
the setting of rhel6 host system in detail. Instructions for kvm host
on rhel5 and rhel6 are slightly different.

Please see 'Additional info:' in comment 0.
Comment 5 Lana Brindley 2012-01-03 19:46:42 EST
Hi Šimon,

Xen instructions still exist in the RHEL 5 section. Can you please be specific as to what changes are still required?

LKB
Comment 6 Šimon Lukašík 2012-01-04 04:18:05 EST
Hello Lana,

I am sorry, based on 'Additional Info' from comment 0, I can't understand 
what remains unclear? Could you please be more verbose on what is the problem?
Comment 7 Lana Brindley 2012-01-04 15:22:48 EST
Hi Šimon,

I think, at this stage, we need to go through what is existing and call out specifically what needs to be changed. As far as I can see, the requested information is all in there, but I need you to confirm that it is correct.

Note also that this chapter has already been modified by other bug fixes, which has affected content in the 'Additional Info' section from comment 0.

LKB
Comment 8 Šimon Lukašík 2012-01-05 05:58:20 EST
Hello Lana,

I am looking at

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Reference_Guide/chap-Reference_Guide-Virtualization.html

according to comment 0, the following changes still *needs* to be made:


(1) In step 4 of section '10.1.2.2.' please replace package name 'kvm'
    with 'qemu-kvm' (two occurrences). It should then read:

        rpm -q qemu-kvm rhn-virtualization-host
        (...)
        yum install qemu-kvm rhn-virtualization-host
    
(2) In step 4 of section '10.1.2.2.' please add 'python-virtinst' package name 
    to the package listings (two occurrences). It should then read:

        rpm -q qemu-kvm rhn-virtualization-host python-virtinst
        (...)
        yum install qemu-kvm rhn-virtualization-host python-virtinst

(3) In step 4 of section '10.2' please add 'python-virtinst' package name
    to the kvm specific package listings (two occurrences). It should then
    read:

        rpm -q kvm kmod-kvm rhn-virtualization-host python-virtinst
        (...)
        yum install kvm kmod-kvm rhn-virtualization-host python-virtinst

(4) Insert a new step in between steps 4 and 5 in section '10.1.2.2.'.
    The new step should read:

        Based on your processor vendor (should be recognized by /proc/cpuinfo)
        insert the appropriate kvm module to the kernel:
           # modprobe kvm_intel
        or
           # modprobe kvm_amd
        or restart the machine.

(5) Amend the step 5 of '10.2' which is currently xen-specific to contain
    kvm instructions as well. It should also compound something like:

        For Kvm, based on your processor vendor (should be recognized
        by /proc/cpuinfo) insert the appropriate kvm module to the kernel:
           # modprobe kvm_intel
        or
           # modprobe kvm_amd
        or restart the machine.

-------------

Side note: As you see now, we have a lot of duplicity in this part of
documentation. It is because we have rhel5 and rhel6 as separate instructions
although the kvm instructions are almost identical on both rhel5 and rhel6.

(In reply to comment #0)
> I would advice to make a separate section for Xen and Kvm.

I understand that rewriting may take more resources. But it may result in
much more clear text.
Comment 9 Lana Brindley 2012-01-08 19:18:37 EST
(In reply to comment #8)
> Hello Lana,
> 
> I am looking at
> 
> http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Reference_Guide/chap-Reference_Guide-Virtualization.html
> 
> according to comment 0, the following changes still *needs* to be made:
> 
> 
> (1) In step 4 of section '10.1.2.2.' please replace package name 'kvm'
>     with 'qemu-kvm' (two occurrences). It should then read:
> 
>         rpm -q qemu-kvm rhn-virtualization-host
>         (...)
>         yum install qemu-kvm rhn-virtualization-host
> 
> (2) In step 4 of section '10.1.2.2.' please add 'python-virtinst' package name 
>     to the package listings (two occurrences). It should then read:
> 
>         rpm -q qemu-kvm rhn-virtualization-host python-virtinst
>         (...)
>         yum install qemu-kvm rhn-virtualization-host python-virtinst

<screen>
rpm -q qemu-kvm rhn-virtualization-host python-virtinst
</screen>

and

<screen>
yum install qemu-kvm rhn-virtualization-host python-virtinst
</screen>

> 
> (3) In step 4 of section '10.2' please add 'python-virtinst' package name
>     to the kvm specific package listings (two occurrences). It should then
>     read:
> 
>         rpm -q kvm kmod-kvm rhn-virtualization-host python-virtinst
>         (...)
>         yum install kvm kmod-kvm rhn-virtualization-host python-virtinst

<screen>
rpm -q kvm kmod-kvm rhn-virtualization-host python-virtinst
</screen>

and

<screen>
yum install kvm kmod-kvm rhn-virtualization-host python-virtinst
</screen>

> 
> (4) Insert a new step in between steps 4 and 5 in section '10.1.2.2.'.
>     The new step should read:
> 
>         Based on your processor vendor (should be recognized by /proc/cpuinfo)
>         insert the appropriate kvm module to the kernel:
>            # modprobe kvm_intel
>         or
>            # modprobe kvm_amd
>         or restart the machine.

<listitem>
	<para>
		Restart the machine to pick up the changes, or use the appropriate <command>modprobe</command> command for your processor:
	</para>
<screen>
modprobe kvm_intel
</screen>
	<para>
		or:
	</para>
<screen>
modprobe kvm_amd
</screen>
</listitem>

> 
> (5) Amend the step 5 of '10.2' which is currently xen-specific to contain
>     kvm instructions as well. It should also compound something like:
> 
>         For Kvm, based on your processor vendor (should be recognized
>         by /proc/cpuinfo) insert the appropriate kvm module to the kernel:
>            # modprobe kvm_intel
>         or
>            # modprobe kvm_amd
>         or restart the machine.

Added the extra step. As far as I can see, this section already contains both xen and kvm instructions.

> 
> -------------
> 
> Side note: As you see now, we have a lot of duplicity in this part of
> documentation. It is because we have rhel5 and rhel6 as separate instructions
> although the kvm instructions are almost identical on both rhel5 and rhel6.
> 
> (In reply to comment #0)
> > I would advice to make a separate section for Xen and Kvm.
> 
> I understand that rewriting may take more resources. But it may result in
> much more clear text.

I can appreciate that, but to be fair, the entire document needs to be rewritten, not just this section. Currently, a rewrite is not feasible.

Revision 2-6

LKB
Comment 10 John Skeoch 2012-01-11 20:08:08 EST
Verified in:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4/html-single/Reference_Guide/index.html#chap-Reference_Guide-Virtualization

Red_Hat_Network_Satellite-Reference_Guide-5.4-en-US-2-6

---

Note You need to log in before you can comment on or make changes to this bug.