Bug 7076 - rp3 confirm start/stop connection button feature within applet
rp3 confirm start/stop connection button feature within applet
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-17 09:09 EST by Charles R. Tersteeg
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 23:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles R. Tersteeg 1999-11-17 09:09:49 EST
The button works fine, but applet still prompts the user (yes or no) to
connect and disconnect from the connection.
Comment 1 Michael K. Johnson 1999-11-19 18:03:59 EST
I'm sorry, I don't understand.  What's the bug here?  Could you restate
the problem?  Thanks.
Comment 2 Charles R. Tersteeg 1999-11-20 11:10:59 EST
latest download fixed problem
chuck
aa0na@arrl.net
Comment 3 jmmartin 1999-11-20 11:49:59 EST
In setting the properties for rp3, the confirm start/stop buttons set
the values in .gnome/rp3 to true when checked, but rp3 misinterprets
the settings in .gnome/rp3.  It asks for confirmation if confirmStart
or confirmStop are set to false, and doesn't ask if they are set to true.

In this latest version, the property names are wrong - they have the last
character lopped off, e.g. confirmStar=true, etc.
Due to this, it adds a duplicate set of property names (except with
the last char gone) to the file.  There is even more confusion, because the
properties dialog reads the first set, but rp3 interprets the second
(truncated) set.  So here's part of my ~/.gnome/rp3 file:

[ppp0]
watchCost=false
confirmStart=false
confirmStop=true
terminateOnClose=false
PriceUnit=3600
pricePerSecond=0
watchCos=false
confirmStar=true
confirmSto=true
terminateOnClos=false
PriceUni=3600
pricePerSecon=0

So the properties dialog shows confirmStart unchecked, but rp3 actually
does not ask for confirmation on start, since confirmStar=true.
Very confusing, but easily fixed, I would think.
Comment 4 Michael K. Johnson 1999-11-22 11:54:59 EST
Sounds like aa0na and jmmartin have different problems...

No, it's not easy to fix, for a few reasons, one of which is that I
cannot reproduce it, and another is that we never pass in those
truncated strings.

However, it is possible that a workaround for a limitation in gcc
that we did for alpha will also fix this; this might be a different
manifestation of the same or a similar bug.  In order to check, please
download a testing release and try it out:
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm
Please report here on its success or failure.

Note that the fixed one, if it is fixed, will ignore but not remove
the mangled entries; you'll have to remove those yourself with a text
editor if you care about them.
Comment 5 jmmartin 1999-11-22 23:46:59 EST
Is rp3 1.0.2 from people.redhat.com the same as rawhide version?
The new version from people.redhat.com has the same behavior on my system
as the rawhide version - writes truncated strings and now I think seems
to ignore the ~/.gnome/rp3 file altogether and never asks for confirmation,
regardless of what's in the rp3 file.  My system is vanilla 6.1 with all
errata applied, and October gnome rpms installed.
Comment 6 Michael K. Johnson 1999-12-01 16:14:59 EST
Yes, it's the same as 1.0.2 in rawhide.

If you remove ~/.gnome/rp3 and then run rp3 again, it still gets
corrupted?  I can't reproduce this here, nohow.  Nowhere in the
rp3 source code is there an instance of the truncated names, so
it is happening somewhere else.  Perhaps it's some problem in the
october gnome libraries?

------- Email Received From  Jan Martin <jmmartin@ktb.net> 12/01/99 23:19 -------
Comment 7 Michael K. Johnson 1999-12-02 15:56:59 EST
To look for this, you'll probably want to work backwards.  Start with
utils/conf.c and see if the section and key variables are mangled in
the conf_set_* functions (you can simply drop fprintf(stderr, ...) in
to check that) and then you'll know whether the october gnome libraries
are mangling the strings or if they are mangled when they get to the
conf.c functions.

Thanks for looking into this!  It's hard to guess these things when
we can't reproduce them...

------- Email From  Jan Martin <jmmartin@ktb.net> 12/11/99 16:03 -------
Attached to Bug # 7076.


------- Email From  Jan Martin <jmmartin@ktb.net> 12/11/99 16:33 -------
Attached to Bug # 7076.


------- Email From  Jan Martin <jmmartin@ktb.net> 12/11/99 19:57 -------
Attached to Bug # 7076.
Comment 8 Jan Carlson 2000-01-23 14:55:59 EST
confirmSto=true appears in ~/.gnome/rp3 (last character of "Stop" truncated)
after attempting to configure rp3 to ask for confirmation when stopping
the connection.  It happens even after removing  ~/.gnome/rp3 and restarting
rp3. rp3 still does not ask for confirmation before stopping the connection.

This is reproducible in rawhide rpms rp3-1.0.5-1.i386.rpm an
rp3-1.0.4-1.i386.rpm as well as in
ftp://people.redhat.com/johnsonm/rp3/rp3-1.0.2-1.i386.rpm

The bug does not appear in rp3-1.0.1-1.i386.rpm from the errata.
Comment 9 Nalin Dahyabhai 2000-02-04 23:21:59 EST
I suspect this was an intermittent problem with the configuration module's
use of alloca() to build the configuration directive names.  This has been
changed in 1.0.7, which is now in Raw Hide.  Please let me know if this
does or doesn't fix the problem.
Comment 10 Brent Fox 2002-06-05 00:58:02 EDT
Closing because we don't ship rp3 anymore.

Note You need to log in before you can comment on or make changes to this bug.