Bug 707752 - may need a dbus-x11 package dependency for subscription-manager-gnome
may need a dbus-x11 package dependency for subscription-manager-gnome
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: 6.2
Assigned To: Chris Duryee
John Sefler
:
Depends On:
Blocks: rhsm-rhel62 736749
  Show dependency treegraph
 
Reported: 2011-05-25 16:25 EDT by John Sefler
Modified: 2011-12-06 12:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 736749 (view as bug list)
Environment:
Last Closed: 2011-12-06 12:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-05-25 16:25:58 EDT
Description of problem:
After provisioning an ia64 machine for RHEL57 on beaker, I get subscription-manager package installed, but not subscription-manager-gnome.  After successfully yum installing subscription-manager-gnome, I run subscription-manager-gui and get a traceback...

Version-Release number of selected component (if applicable):
[root@hp-bl860c-01 tmp]# rpm -qa | grep subscription-manager
subscription-manager-0.95.5.18-1.el5
subscription-manager-gnome-0.95.5.18-1.el5


How reproducible:


Steps to Reproduce:
1. provision an ia64 box with RHEL57. (you can clone https://beaker.engineering.redhat.com/jobs/89203).  I got machine hp-bl860c-01.rhts.eng.bos.redhat.com

[jsefler@jsefler ~]$ ssh -XYC root@hp-bl860c-01.rhts.eng.bos.redhat.com
Warning: Permanently added 'hp-bl860c-01.rhts.eng.bos.redhat.com,10.16.65.35' (RSA) to the list of known hosts.
root@hp-bl860c-01.rhts.eng.bos.redhat.com's password: 
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
                 This System is reserved by jsefler@redhat.com.

 To return this system early. You can run the command: return2beaker.sh
  Ensure you have your logs off the system before returning to Beaker

 To extend your reservation time. You can run the command:
  extendtesttime.sh
 This is an interactive script. You will be prompted for how many
  hours you would like to extend the reservation.
  Please use this command responsibly, Everyone uses these machines.

 You should verify the watchdog was updated succesfully after
  you extend your reservation.
  https://beaker.engineering.redhat.com/recipes/183144

 For ssh, kvm, serial and power control operations please look here:
  https://beaker.engineering.redhat.com/view/hp-bl860c-01.rhts.eng.bos.redhat.com

      Beaker Test information:
                         HOSTNAME=hp-bl860c-01.rhts.eng.bos.redhat.com
                            JOBID=89203
                         RECIPEID=183144
                    RESULT_SERVER=127.0.0.1:7098
                           DISTRO=RHEL5.7-Server-20110518.0
                     ARCHITECTURE=ia64
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
/usr/bin/xauth:  creating new authority file /root/.Xauthority
[root@hp-bl860c-01 ~]# rpm -q subscription-manager
subscription-manager-0.95.5.18-1.el5

  [root@hp-bl860c-01 ~]# yum install subscription-manager-gnome
Loaded plugins: product-id, security, subscription-manager
Updating Red Hat repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package subscription-manager-gnome.ia64 0:0.95.5.18-1.el5 set to be updated
--> Processing Dependency: librsvg2 for package: subscription-manager-gnome
--> Processing Dependency: gnome-python2-canvas for package: subscription-manager-gnome
--> Processing Dependency: usermode-gtk for package: subscription-manager-gnome
--> Running transaction check
---> Package gnome-python2-canvas.ia64 0:2.16.0-1.fc6 set to be updated
---> Package librsvg2.ia64 0:2.16.1-1.el5 set to be updated
--> Processing Dependency: libcroco >= 0.6.1 for package: librsvg2
--> Processing Dependency: libgsf >= 1.6.0 for package: librsvg2
--> Processing Dependency: libgsf-1.so.114()(64bit) for package: librsvg2
--> Processing Dependency: libcroco-0.6.so.3()(64bit) for package: librsvg2
---> Package usermode-gtk.ia64 0:1.88-3.el5.2 set to be updated
--> Running transaction check
---> Package libcroco.ia64 0:0.6.1-2.1 set to be updated
---> Package libgsf.ia64 0:1.14.1-6.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================
 Package                                       Arch                    Version                             Repository                        Size
==================================================================================================================================================
Installing:
 subscription-manager-gnome                    ia64                    0.95.5.18-1.el5                     beaker-Server                    115 k
Installing for dependencies:
 gnome-python2-canvas                          ia64                    2.16.0-1.fc6                        beaker-Server                     28 k
 libcroco                                      ia64                    0.6.1-2.1                           beaker-Server                    160 k
 libgsf                                        ia64                    1.14.1-6.1                          beaker-Server                    153 k
 librsvg2                                      ia64                    2.16.1-1.el5                        beaker-Server                    245 k
 usermode-gtk                                  ia64                    1.88-3.el5.2                        beaker-Server                    136 k

Transaction Summary
==================================================================================================================================================
Install       6 Package(s)
Upgrade       0 Package(s)

Total download size: 836 k
Is this ok [y/N]: y
Downloading Packages:
(1/6): gnome-python2-canvas-2.16.0-1.fc6.ia64.rpm                                                                          |  28 kB     00:00     
(2/6): subscription-manager-gnome-0.95.5.18-1.el5.ia64.rpm                                                                 | 115 kB     00:00     
(3/6): usermode-gtk-1.88-3.el5.2.ia64.rpm                                                                                  | 136 kB     00:00     
(4/6): libgsf-1.14.1-6.1.ia64.rpm                                                                                          | 153 kB     00:00     
(5/6): libcroco-0.6.1-2.1.ia64.rpm                                                                                         | 160 kB     00:00     
(6/6): librsvg2-2.16.1-1.el5.ia64.rpm                                                                                      | 245 kB     00:00     
--------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                             4.3 MB/s | 836 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libgsf                                                                                                                     1/6 
  Installing     : gnome-python2-canvas                                                                                                       2/6 
  Installing     : usermode-gtk                                                                                                               3/6 
  Installing     : libcroco                                                                                                                   4/6 
  Installing     : librsvg2                                                                                                                   5/6 
  Installing     : subscription-manager-gnome                                                                                                 6/6 
duration: 3079(ms)
Installed products updated.

Installed:
  subscription-manager-gnome.ia64 0:0.95.5.18-1.el5                                                                                               

Dependency Installed:
  gnome-python2-canvas.ia64 0:2.16.0-1.fc6       libcroco.ia64 0:0.6.1-2.1       libgsf.ia64 0:1.14.1-6.1       librsvg2.ia64 0:2.16.1-1.el5      
  usermode-gtk.ia64 0:1.88-3.el5.2              

Complete!
[root@hp-bl860c-01 ~]# subscription-manager-gui 

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.

(subscription-manager-gui:4683): libglade-WARNING **: unknown attribute `swapped' for <signal>.
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager-gui", line 100, in ?
    bus_name = dbus.service.BusName(BUS_NAME, bus = dbus.SessionBus())
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 266, in __new__
    return Bus.__new__(cls, Bus.TYPE_SESSION, use_default_mainloop, private)
  File "/usr/lib/python2.4/site-packages/dbus/_dbus.py", line 99, in __new__
    bus._connection = dbus_bindings.bus_get(bus_type, private)
  File "dbus_bindings.pyx", line 1692, in dbus_bindings.bus_get
dbus_bindings.DBusException: Failed to execute dbus-launch to autolaunch D-Bus session
[root@hp-bl860c-01 ~]#


Actual results:
the subscription-manager-gui did not open and the dbus traceback above was printed.

Expected results:
the subscription-manager-gui should open in your display


Additional info:
[root@hp-bl860c-01 tmp]# rpm -q subscription-manager-gnome --requires
/bin/sh  
/bin/sh  
/bin/sh  
/usr/bin/python  
gnome-python2  
gnome-python2-canvas  
libatk-1.0.so.0()(64bit)  
libc.so.6.1()(64bit)  
libc.so.6.1(GLIBC_2.2)(64bit)  
libcairo.so.2()(64bit)  
libdbus-1.so.3()(64bit)  
libdbus-glib-1.so.2()(64bit)  
libdl.so.2()(64bit)  
libgdk-x11-2.0.so.0()(64bit)  
libgdk_pixbuf-2.0.so.0()(64bit)  
libglib-2.0.so.0()(64bit)  
libgmodule-2.0.so.0()(64bit)  
libgobject-2.0.so.0()(64bit)  
libgtk-x11-2.0.so.0()(64bit)  
libm.so.6.1()(64bit)  
libnotify.so.1()(64bit)  
libpango-1.0.so.0()(64bit)  
libpangocairo-1.0.so.0()(64bit)  
librsvg2  
pygtk2  
pygtk2-libglade  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
subscription-manager = 0.95.5.18-1.el5
usermode  
usermode-gtk  



Note:  After yum install dbus-x11, the subscription-manager-gui started up
Comment 4 John Sefler 2011-09-08 11:32:01 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.96.9-1.git.1.983fb44.el6.x86_64

[root@jsefler-onprem-62server ~]# rpm -q subscription-manager-gnome --requires
/bin/sh  
/bin/sh  
/bin/sh  
/usr/bin/python  
dbus-x11  
gnome-python2  
gnome-python2-canvas  
libatk-1.0.so.0()(64bit)  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libcairo.so.2()(64bit)  
libdbus-1.so.3()(64bit)  
libdbus-glib-1.so.2()(64bit)  
libfontconfig.so.1()(64bit)  
libfreetype.so.6()(64bit)  
libgdk-x11-2.0.so.0()(64bit)  
libgdk_pixbuf-2.0.so.0()(64bit)  
libgio-2.0.so.0()(64bit)  
libglib-2.0.so.0()(64bit)  
libgmodule-2.0.so.0()(64bit)  
libgobject-2.0.so.0()(64bit)  
libgtk-x11-2.0.so.0()(64bit)  
libnotify.so.1()(64bit)  
libpango-1.0.so.0()(64bit)  
libpangocairo-1.0.so.0()(64bit)  
libpangoft2-1.0.so.0()(64bit)  
libpthread.so.0()(64bit)  
librsvg2  
librt.so.1()(64bit)  
pygtk2  
pygtk2-libglade  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
subscription-manager = 0.96.9-1.git.1.983fb44.el6
usermode  
usermode-gtk  
rpmlib(PayloadIsXz) <= 5.2-1
[root@jsefler-onprem-62server ~]# 

^^^ dbus-x11 is now included in the requires package list for subscription-manager-gnome

moving to VERIFIED
Comment 5 errata-xmlrpc 2011-12-06 12:14:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.