Bug 707758 - Scaling and fit to VM broken with SPICE
Scaling and fit to VM broken with SPICE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 699454 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-25 16:43 EDT by Michael Monreal
Modified: 2012-02-14 03:56 EST (History)
7 users (show)

See Also:
Fixed In Version: virt-manager-0.9.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-14 03:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2011-05-25 16:43:08 EDT
VMs using SPICE fail to properly scale or fit to the VM window size.

virt-manager-0.8.7-4.fc15.noarch
spice-gtk3-0.5-6.fc15.x86_64
spice-client-0.8.1-1.fc15.x86_64
spice-gtk-0.5-6.fc15.x86_64
spice-glib-0.5-6.fc15.x86_64
spice-gtk-python-0.5-6.fc15.x86_64
spice-server-0.8.1-1.fc15.x86_64
Comment 1 Marc-Andre Lureau 2011-06-03 09:03:32 EDT

Spice and spice-gtk supports resizing guest to best match, and also scaling. Both options are independent, and can be enabled simultaneously.

Currently, virt-manager scaling option is mapped to resize the guest only. We might want to change that and introduce a new "Resize the guest" option indepedent to "Scale to VM".
Comment 2 Cole Robinson 2011-07-11 12:50:41 EDT
*** Bug 699454 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2011-07-11 12:51:39 EDT
'Resize to guest' is implemented for SPICE in upstream virt-manager (thanks to
elmarco). Any other improvements should be tracked in separate BZs
Comment 4 Fedora Update System 2012-02-01 13:24:19 EST
virt-manager-0.9.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/virt-manager-0.9.1-1.fc15
Comment 5 Fedora Update System 2012-02-02 12:23:44 EST
Package virt-manager-0.9.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1173/virt-manager-0.9.1-1.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-02-14 03:56:46 EST
virt-manager-0.9.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.