Bug 7079 - make 3.77 is a broken release
make 3.77 is a broken release
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-17 11:41 EST by amundson
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-03 11:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description amundson 1999-11-17 11:41:16 EST
GNU make 3.77 was a bad release. It contains a bug that
completely kills our local build system. (I've included a
copy of the bug report I sent to the GNU make maintainers at
the end of this message.) From searching bugzilla, I see
that there is at least one other serious bug in 3.77. It was
reported in bug #2074.

GNU Make 3.78.1 has been released. It seems to be better;
the bug I reported is fixed, at least. Since Redhat has been
shipping a broken make for two releases now (6.0 and 6.1),
it really needs to be fixed.

--Jim Amundson
  amundson@fnal.gov


Here is a copy of the bug report I submitted to the GNU make
maintainers on July 2, 1999:

Hello,

I would like to report a bug in GNU Make 3.77. If one "-include"s a
file that does not exist once, make ignores the command and continues.
If the same file is "-included" a second time, make stops with "No
rule to make target". This behavior was not present in GNU make
3.76.1.

Here is a short example:

----GNUmakefile.single-------
-include never_there
all: ; @echo "Success"
-----------------------------

----GNUmakefile.double-------
-include never_there
-include never_there
all: ; @echo "Success"
-----------------------------

------------------------------------------------------------------
> gmake --version
GNU Make version 3.76.1, by Richard Stallman and Roland McGrath.
Copyright (C) 1988, 89, 90, 91, 92, 93, 94, 95, 96, 97
        Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

Report bugs to <bug-gnu-utils@prep.ai.mit.edu>.

> gmake377 --version
GNU Make version 3.77, by Richard Stallman and Roland McGrath.
Copyright (C) 1988, 89, 90, 91, 92, 93, 94, 95, 96, 97, 98
        Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

Report bugs to <bug-make@gnu.org>.

> gmake -f GNUmakefile.single
Success
> gmake -f GNUmakefile.double
Success
> gmake377 -f GNUmakefile.single
Success
> gmake377 -f GNUmakefile.double
gmake377: *** No rule to make target `never_there'.  Stop.

------------------------------------------------------------------

I am using Linux with the 2.2.9 kernel and glibc 2.0.7. I have
attached my config.h from the make build.

Thank you,
Jim Amundson

(config.h file omitted for brevity)
Comment 1 Jeff Johnson 1999-12-03 11:40:59 EST
make-3.78.1 is packaged in Raw Hide. Please reopen this bug if that version
of make does not fix your problem.

Note You need to log in before you can comment on or make changes to this bug.