This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 707957 - clutter-gtkmm refuses to compile
clutter-gtkmm refuses to compile
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clutter-gtkmm (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ryan H. Lewis (rhl)
Fedora Extras Quality Assurance
:
: 716186 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 08:23 EDT by Banana Fool
Modified: 2011-08-26 15:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: clutter-gtkmm-0.91.8-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-26 15:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Banana Fool 2011-05-26 08:23:24 EDT
Try to compile this minimal testcase:

int main() { return 0; }

$ gcc `pkg-config --libs --cflags gtkmm-3.0 cluttermm-1.0 clutter-gtkmm-1.0` testcase.cc

/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_texture_new_from_pixbuf'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `virtual thunk to Gtk::SizeRequest::~SizeRequest()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `non-virtual thunk to Gtk::Container::~Container()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_light_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::on_no_expose_event(_GdkEventAny*)'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_texture_new_from_stock'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_text_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_fg_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::SizeRequest::~SizeRequest()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_texture_new_from_icon_name'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `non-virtual thunk to Gtk::Widget::~Widget()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_dark_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::on_style_changed(Glib::RefPtr<Gtk::Style> const&)'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::on_expose_event(_GdkEventExpose*)'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `typeinfo for Gtk::SizeRequest'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_base_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_text_aa_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `virtual thunk to Gtk::SizeRequest::~SizeRequest()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_bg_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::on_size_request(_GtkRequisition*)'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::hide_all_vfunc()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `non-virtual thunk to Gtk::Widget::~Widget()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::SizeRequest::~SizeRequest()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `gtk_clutter_get_mid_color'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `non-virtual thunk to Gtk::Container::~Container()'
/usr/lib/gcc/i686-redhat-linux/4.6.0/../../../libclutter-gtkmm-1.0.so: undefined reference to `Gtk::Widget::on_client_event(_GdkEventClient*)'
collect2: ld returned 1 exit status
Comment 2 Ryan H. Lewis (rhl) 2011-05-29 10:22:30 EDT
indeed, the fedora packages seem to be in need of updating, I have this same problem!
Comment 3 Ryan H. Lewis (rhl) 2011-05-29 10:38:41 EDT
It looks like we have an f14 package which fixes this bug, may we get an f15 package update as well: http://koji.fedoraproject.org/koji/buildinfo?buildID=174696 ?
Comment 4 Ryan H. Lewis (rhl) 2011-06-30 20:24:07 EDT
After speaking with the upstream developers, they have made a new release: 

http://ftp.acc.umu.se/pub/GNOME/sources/clutter-gtkmm/0.91/

they mentioned there is also a new release of cluttermm.

I will try and package this, but I am busy right now, and I am also not an actual fedora packager (yet). So I am using this bug report like a call in the wilderness, for someone to fix this problem.
Comment 5 Ryan H. Lewis (rhl) 2011-08-15 22:52:37 EDT
If anyone wants to test this SRPM on there system, i've packaged the above release: 

http://fedorapeople.org/~rhl/clutter-gtkmm-0.91.8-3.fc15.src.rpm

i'll be submitting the SRPM for review asap.
Comment 6 Ryan H. Lewis (rhl) 2011-08-17 02:02:06 EDT
*** Bug 716186 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Admin XMLRPC Client 2011-08-17 11:03:54 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Update System 2011-08-17 12:20:51 EDT
clutter-gtkmm-0.91.8-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/clutter-gtkmm-0.91.8-3.fc15
Comment 9 Fedora Update System 2011-08-17 22:35:18 EDT
Package clutter-gtkmm-0.91.8-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clutter-gtkmm-0.91.8-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/clutter-gtkmm-0.91.8-3.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-08-26 15:01:05 EDT
clutter-gtkmm-0.91.8-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.