Bug 70810 - /bin/vi tries to parse vimrc config files
Summary: /bin/vi tries to parse vimrc config files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-05 18:00 UTC by Marc MERLIN
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 14:35:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc MERLIN 2002-08-05 18:00:58 UTC
So why is it bad?
Well, /bin/vi is a very stripped down version of vim (by design), and fails
miserably to parse most directives in vimrc files.
Worse: while I haven't looked at the exact reason why, if I run /bin/vi and
it's able to load my /usr/share/vim/vim61/macros/vimrc file (which should not
be there, it should be in /etc/vim, see bug 70809), it fails to parse it correctly
but in the process it actually clobbers the file I was editing and saves the
empty version (I'm not kidding)

I've edited my /bin/vi binary so that it tries to load ~/.virc and
/usr/share/vim/vim61/macros/virc, which allows for having a minimal config file
that /bin/vi can parse

Ideally, when you build /bin/vi, you should have it read a different config file
than /usr/bin/vim


Note You need to log in before you can comment on or make changes to this bug.