Bug 708104 - "renew_all_tgts" and "renew_handlers" messages are being logged multiple times when the provider comes back online.
"renew_all_tgts" and "renew_handlers" messages are being logged multiple time...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sssd (Show other bugs)
5.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
Chandrasekar Kannan
:
Depends On: 708009
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 14:29 EDT by Stephen Gallagher
Modified: 2015-01-04 18:48 EST (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.5.1-38.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 708009
Environment:
Last Closed: 2012-02-21 01:22:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Stephen Gallagher 2011-09-30 08:31:01 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/882
Comment 2 Kaushik Banerjee 2011-12-21 08:41:31 EST
Steps to verify:

1. Configure sssd for auto renewal and start sssd.
2. Login as a user to get a renewable ticket.
3. Stop KDC.
4. Wait for provider to go offline.
5. Start KDC.
6. Check log for "[renew_all_tgts] (9): Checking [FILE:/tmp/krb5cc_XXXX_XXXXX] for renewal at [Wed Dec 21 19:09:17 2011]" messages.

Repeat steps 2-6 for about 3 cycles.

"renew_all_tgts" and "renew_handler" messages no longer appear multiple times.


Verified in version:
# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.5.1                             Vendor: Red Hat, Inc.
Release     : 47.el5                        Build Date: Tue 13 Dec 2011 07:19:10 PM IST
Install Date: Wed 14 Dec 2011 12:37:28 PM IST      Build Host: x86-007.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.5.1-47.el5.src.rpm
Size        : 3679892                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 3 errata-xmlrpc 2012-02-21 01:22:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0164.html

Note You need to log in before you can comment on or make changes to this bug.