Bug 708205 - NFS Service is always changed to be exclusive by luci
Summary: NFS Service is always changed to be exclusive by luci
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
: 717259 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-26 22:14 UTC by joshua
Modified: 2018-11-28 21:41 UTC (History)
6 users (show)

Fixed In Version: luci-0.23.0-15.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 09:45:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 58605 None None None Never
Red Hat Product Errata RHBA-2011:1510 normal SHIPPED_LIVE luci bug fix update 2011-12-06 00:39:20 UTC

Description joshua 2011-05-26 22:14:45 UTC
Description of problem:

Everytime I bring up my NFS service definition in luci, it has the exclusive checkmark checked, even when there is no mention of exclusive in the cluster.conf file.  If someone doesn't notice this, changes something else, then clicks on submit, their NFS service will turn exclusive without them knowing it, like it did to me here:

$ sudo grep exclusive /etc/cluster/cluster.conf
		<service exclusive="1" name="CDTG NFS" recovery="relocate">




Version-Release number of selected component (if applicable):

RHEL 6.1 everything, luci-0.23.0-13.el6.x86_64

Comment 4 Ryan McCabe 2011-06-28 17:27:56 UTC
*** Bug 717259 has been marked as a duplicate of this bug. ***

Comment 6 joshua 2011-08-16 16:24:00 UTC
BTW, this seems to be true of all services, not just NFS.

Comment 9 errata-xmlrpc 2011-12-06 09:45:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1510.html


Note You need to log in before you can comment on or make changes to this bug.