Bug 708254 - systemd logs excessively at DEBUG level: syslog configuration needs to discard these
Summary: systemd logs excessively at DEBUG level: syslog configuration needs to discar...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog
Version: 15
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tomas Heinrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-27 03:17 UTC by Philip Prindeville
Modified: 2016-09-20 04:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-27 15:59:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 705427 None None None Never

Internal Links: 705427

Description Philip Prindeville 2011-05-27 03:17:43 UTC
Description of problem:

Following the commit of #705427, systemd now generates the following messages at Debug level:

May 26 09:01:01 localhost /usr/sbin/crond[5136]: pam_systemd(crond:session): Moving new user session for root into control group /user/root/67.
May 26 09:01:01 localhost /USR/SBIN/CROND[5136]: pam_systemd(crond:session): Moving remaining processes of user session 67 of root into control group /user/root/master.

as a consequence of authpriv.* being logged to /var/log/secure.  The fix is to raise this to "authpriv.info" instead.


Version-Release number of selected component (if applicable):

5.7.9-2.fc15

How reproducible:

Not necessary... a running f15 system should do this by default.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Lots of the above logs (one every hour).

Expected results:

Nothing, as the above log messages are non-exceptional indications (i.e. normal behavior).

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=705427

Comment 1 Michal Schmidt 2011-05-27 07:47:05 UTC
Tomáš,

in bug 705427 I said:
> I believe changing the rsyslog configuration should not be necessary.
> pam_systemd should stop producing debug messages by default. This is the patch
> I mentioned:
> http://lists.freedesktop.org/archives/systemd-devel/2011-May/002531.html

Please wait for Lennart's response before doing this change to the default rsyslog.conf.

Comment 2 Philip Prindeville 2011-05-29 00:16:25 UTC
(In reply to comment #1)
> Tomáš,
> 
> in bug 705427 I said:
> > I believe changing the rsyslog configuration should not be necessary.
> > pam_systemd should stop producing debug messages by default. This is the patch
> > I mentioned:
> > http://lists.freedesktop.org/archives/systemd-devel/2011-May/002531.html
> 
> Please wait for Lennart's response before doing this change to the default
> rsyslog.conf.

Looking at that patch, it doesn't seem to touch rsyslog... in fact, it adds a gating variable to calling syslog() so that debugging messages can be turned off altogether (which is a bit odd, since the logging level also functions as the gating variable).

Comment 3 Michal Schmidt 2011-05-30 11:21:22 UTC
(In reply to comment #2)
> Looking at that patch, it doesn't seem to touch rsyslog...

Correct.

> in fact, it adds a gating variable to calling syslog() so that debugging
> messages can be turned off altogether

Yes. The debug messages will be off by default. It's similar to other PAM modules in this regard.

> (which is a bit odd, since the logging level also functions as
> the gating variable).

True, but is more efficient to stop emitting the messages altogether, than to wake syslog only to have them discarded (in the usual configuration).

Comment 4 Michal Schmidt 2011-06-15 22:01:37 UTC
systemd-26-4.fc15, which I have just submitted to updates-testing, does not log debug messages by default anymore.

I recommend WONTFIX for this bug.


Note You need to log in before you can comment on or make changes to this bug.