Bug 70829 - Control panel to switch window managers
Summary: Control panel to switch window managers
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-center   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-05 21:47 UTC by Wil Coulbourn
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 23:16:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wil Coulbourn 2002-08-05 21:47:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The earlier versions of control-center (e.g. the 1.5.x versions) had a separate
rpm called control-center-plus.  This held the advanced tab and contained the
ability to change the window manager within gnome.  The 2nd public beta of limbo
does not include this package and as yet I have found no way to change the
window manager within gnome.  Switchdesk-gnome is not an option.  This would set
up a different window manager OUTSIDE of gnome.  What i'm looking for is to
change the window manager inside.  So instead of sawfish say, I could use
WindowMaker or twm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

Additional info:

Comment 1 Havoc Pennington 2002-12-19 23:16:16 UTC
Putting the term "window manager" in the GUI isn't really an option.
Changing window managers more or less breaks the user interface from
the standpoint of most users.

The correct way to switch is simple, say to go from metacity to fvwm2:

$ fvwm2 -replace
$ gnome-session-save

This is somewhat complicated because some window managers don't support session
management (so you have to add them to the session in gnome-session-properties), 
or don't support -replace or --replace (so you have to killall the existing WM). 
But it's basically a sane mechanism. Encourage your upstream window manager
maintainer to support SM and -replace/--replace (technical implementation of
-replace is "ICCCM WM_Sn selection" if they ask). 


Note You need to log in before you can comment on or make changes to this bug.