Bug 708300 - as7: Investigate (and use) connection pooling for connections to AS
as7: Investigate (and use) connection pooling for connections to AS
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-05-27 04:07 EDT by Heiko W. Rupp
Modified: 2011-10-04 15:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 16:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-05-27 04:07:47 EDT
Currently for each request a new connection is opened.
This is not the most efficient way due to TCP 3-way handshake - especially for remote servers.

Investigate using connection pooling 
- does as7 support it
- is it really faster
- what are memory changes
- does it allow secure connections?

If the answers are positive, implement it.
Comment 1 Heiko W. Rupp 2011-08-16 11:09:52 EDT
The JRE provides pooling out of the box (when requests are at most 7sec apart from each other), so there is no need to do anything.

Note You need to log in before you can comment on or make changes to this bug.