This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 708305 - C program compiled with pcc doesn't work
C program compiled with pcc doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcc (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Susi Lehtola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 04:26 EDT by Hong Xu
Modified: 2011-12-31 13:58 EST (History)
2 users (show)

See Also:
Fixed In Version: pcc-1.0.0-2.20111216cvs.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-24 15:51:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hong Xu 2011-05-27 04:26:29 EDT
Description of problem:
When the c source file is compiled with pcc, the out executable always exit with segmentation fault.

Version-Release number of selected component (if applicable):
pcc-1.0.0-1.fc15.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. write a small c source file:

int main(int argc, const char *argv[])
{
    printf("Hello\n");
    return 0;
}

name it "a.c";

2. execute "pcc a.c";
3. execute "./a.out";
  
Actual results:
a.out exit because of segmentation fault:
Segmentation fault (core dumped)

Expected results:
"Hello" should be printed.
Comment 1 Susi Lehtola 2011-05-27 04:53:05 EDT
I can reproduce this on my F15 machines. pcc works fine in F14. 

Reported upstream at
http://pcc.ludd.ltu.se/jira/browse/PCC-353
Comment 2 Hong Xu 2011-05-27 05:17:06 EDT
(In reply to comment #1)
> I can reproduce this on my F15 machines. pcc works fine in F14. 
> 
> Reported upstream at
> http://pcc.ludd.ltu.se/jira/browse/0

The link seems broken?
Comment 3 Susi Lehtola 2011-05-27 06:01:42 EDT
should be
http://pcc.ludd.ltu.se/jira/browse/PCC-353
Comment 4 Fedora Update System 2011-12-16 07:32:44 EST
pcc-1.0.0-2.20111216cvs.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pcc-1.0.0-2.20111216cvs.el6
Comment 5 Fedora Update System 2011-12-16 07:32:52 EST
pcc-1.0.0-2.20111216cvs.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pcc-1.0.0-2.20111216cvs.fc15
Comment 6 Fedora Update System 2011-12-16 07:33:01 EST
pcc-1.0.0-2.20111216cvs.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pcc-1.0.0-2.20111216cvs.fc16
Comment 7 Fedora Update System 2011-12-16 07:33:09 EST
pcc-1.0.0-2.20111216cvs.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pcc-1.0.0-2.20111216cvs.el5
Comment 8 Fedora Update System 2011-12-16 12:41:52 EST
Package pcc-1.0.0-2.20111216cvs.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pcc-1.0.0-2.20111216cvs.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-5252/pcc-1.0.0-2.20111216cvs.el6
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-12-24 15:51:04 EST
pcc-1.0.0-2.20111216cvs.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-12-24 15:52:32 EST
pcc-1.0.0-2.20111216cvs.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-12-31 13:58:38 EST
pcc-1.0.0-2.20111216cvs.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2011-12-31 13:58:59 EST
pcc-1.0.0-2.20111216cvs.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.