Bug 708306 - as7: Allow to connect to secured servers
as7: Allow to connect to secured servers
Status: CLOSED DUPLICATE of bug 754849
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: ---
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-05-27 04:29 EDT by Heiko W. Rupp
Modified: 2012-02-09 07:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-09 07:09:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-05-27 04:29:43 EDT
AS 7 servers (host controllers) may be secured via password or x509 cert or ..

We need to make sure that the plugin can connect to those.

Also ssl may come into play


There are two aspects to this:
- add connection properties for the user and credentials
- try to detect and auto fill user and credentials; where credentials will probably no longer exist anywhere in the server configuration.
Comment 1 Heiko W. Rupp 2011-08-16 11:58:50 EDT
Passwords are automatically detected,
connection properties are present.

as7 is using Digest authentication, which is not completely trivial to implement
Comment 2 Heiko W. Rupp 2011-08-16 16:16:27 EDT
No blocker for rhq4.1 as the user can still connect without authentication
Comment 3 Charles Crouch 2011-10-04 14:07:14 EDT
Setting priority on enhancements to as7 plugin to high. They don't block the JON3 release, but will be needed for subsequent release
Comment 4 Heiko W. Rupp 2012-02-09 07:09:20 EST

*** This bug has been marked as a duplicate of bug 754849 ***

Note You need to log in before you can comment on or make changes to this bug.