Bug 708314 - Missing realtek usb drivers in modules.networking
Missing realtek usb drivers in modules.networking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 05:13 EDT by Yanko Kaneti
Modified: 2011-08-17 22:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.40.3-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 12:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel spec patch (590 bytes, patch)
2011-05-27 05:13 EDT, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Yanko Kaneti 2011-05-27 05:13:45 EDT
Created attachment 501270 [details]
kernel spec patch

Description of problem:
The install media initrd for Fedora 15 is missing the kernel modules for the realtek rt2x00 drivers.  AFAIK anaconda uses modules.networking as built by the kernel spec to pick which drivers to include in the install initrd.

As far as i understand the kernel spec is not picking up the rt2x00 drivers because of their somewhat unusual module dependency setup.

Attached is a proposed change to the kernel.spec to also look for the realtek specific probe functions rt2x00(pci|usb)_probe which should cover everything relevant in rt2x00
Comment 1 Josh Boyer 2011-08-02 12:58:08 EDT
This will be fixed with the next build of f15, f16, and rawhide.
Comment 2 Fedora Update System 2011-08-16 08:47:39 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 3 Fedora Update System 2011-08-17 22:30:29 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.