Bug 708354 - gnome-shell + nvidia drivers => black windows
gnome-shell + nvidia drivers => black windows
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 07:44 EDT by Iñigo Serna
Modified: 2013-02-01 09:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-10 05:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iñigo Serna 2011-05-27 07:44:47 EDT
Hi, I've updated my computer from F14 to F15 final with the DVD (preupgrade doesn't work as my /boot and / partitions are on md devices).

F15, AMD64, 6GB RAM, nvidia GeForce 6150.
I use propietary nvidia drivers from rpmfusion.

gdm login screen shows perfectly but once the session is started
a) if nautilus handles desktop => there is a black background, no image shown, no icons, no right-click menu with the mouse
b) if nautilus doesn't handle desktop (default in GNOME 3) => background image is shown, but...

in both cases every window/app I open appears as black rectangles, even no windows decorations. Some times, the first app I open is shown correctly, but no more. I know apps are running, but windows are not drawn on screen and appears as black windows.

Topbar "applets" (calendar, user menu, nm-applet, etc) and their menus work ok, and when I press WINDOWS key it shows the Activities screen with no problems, I can see the background, left dock, workspaces at right, search for apps... NO problems, and it's fast.

But when I come back to normal screen, windows are black rectangles (except maybe the first one).


I don't think if problem comes from nvidia drivers but as in F14 I was using gnome-shell at it worked ok, I think issued comes from mutter/gnome-shell => compositor?

Btw, using nouveau driver goes to fallback mode.
My graphics card is a nvidia GeForce 6150, maybe old, but worked ok and even fast with gnome-shell from F14.

I've tried uninstalling rpmfusion drivers and installing old and new/beta drivers from nvidia website, but same problem.

I've search and find other people share same problem with ATI cards [1], that's the reason I think problem is composition or maybe xorg.
[1] https://bugzilla.redhat.com/show_bug.cgi?id=675021


Fallback mode works perfectly with nouveau, that's what I'm using now.

Thanks,
Iñigo Serna
Comment 1 Iñigo Serna 2011-05-29 09:35:03 EDT
I've been testing many things last couple of days, no luck.

I've also been looking carefully at many logs: /var/log/{Xorg.0.log, messages audit/audit.log}, .xsessions-errors, dmesg and glxinfo output... Everything seems correct, no errors.

If you need them I can attach the logs.

Here, another bug I think related to this one: https://bugzilla.redhat.com/show_bug.cgi?id=707650
Comment 2 Iñigo Serna 2011-05-29 11:13:03 EDT
Excuse me for the monologue, but I think I've found something... it looks there are some problems with xorg 1.10 and nvidia drivers 270.x when using KDE and transparency, maybe it's related with the issue I have.

More info:
http://www.nvnews.net/vbulletin/showthread.php?s=bb5e2c560fac5d864d470bc8f01bda04&t=162133
https://bugs.archlinux.org/task/23381
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/760632
Comment 3 Sibi Antony 2011-06-03 18:06:52 EDT
I have the same problem, but with the nouveau drivers. Installed Fedora 15 (Default DVD media), and once I login to Gnome 3, I get a black screen with 'patches' everywhere. My display card is an integrated nvidia GeForce 6150. 

I doubt if it is due to the desktop effects ? Is there any way to turn the effects from command line?
Comment 4 Iñigo Serna 2011-06-04 04:42:43 EDT
I also have  an integrated GeForce 6150, my motherboard is a ASUS M2NPV-VM.

But in my case, it doesn't run GNOME 3, always goes to fallback mode, showing the next error:

[    41.268] (EE) NOUVEAU(0): Error creating GPU channel: -16
[    41.269] (EE) NOUVEAU(0): Error initialising acceleration.  Falling back to NoAccel

Did you do something special?


Anyway, I've read many reports with compositing/transparency errors with xorg 1.10 and nvidia drivers 270.x, so I think there are some bugs there at least.
Comment 5 Sibi Antony 2011-06-04 09:01:47 EDT
Iñigo: After a couple of reboots I realized that the problem occurs only once in a while. 
Whenever I'm logging into GNOME, if I hover my mouse around, there is a good chance that I hit the problem. On other cases (If I leave the mouse as is), the login happens just fine, and GNOME 3 is running too.
I've never tried nvidia binaries, but I think there could be problems to be addressed in Xorg/GNOME 3 ? I cannot access terminal/logs whenever the problem happens, so cannot attach any logs to look for any clues..
Comment 6 Pavel Rosenboim 2011-06-05 02:28:47 EDT
I have same problem. With nouveau, I experienced screen corruption sometimes, and decided to try nvidia drivers. With them, I also see a background and a top bar, but nothing else is drawn.
I installed KDE and it works in this configuration, so, I guess, the problem is on Gnome's side.
Comment 7 Iñigo Serna 2011-06-10 05:15:09 EDT
I've solved my original problem, so I will close the case.
I'm not completely sure about what happened but it looks like a bug of nvidia propietary drivers with last version 1.10 of xorg-server.

In my case, after lots of hours testing I finally got gnome-shell work without those "black windows". 
My graphics card is a GeForce 6150 embedded on an Asus M2NPV-VM mother board.
I took a look at BIOS and saw a setting called "Frame buffer size for onboard graphic", whose value was 32MB, I changed it to the maximum, 256MB, and gnome-shell works now.
Note that with Fedora 14's gnome-shell (xorg 1.9, nvidia 260.x) it worked.

Anyway, nVidia has reproduced the issue (and other regarding screen corruption) on their labs and they are working in a fix. More info on: 
http://www.nvnews.net/vbulletin/showthread.php?s=72d8d925972ec2f4349bcef979adcf70&p=2443529&posted=1#post2443529

Thus, closing the case.
Iñigo

Note You need to log in before you can comment on or make changes to this bug.