Bug 70843 - sawfish menus do not work at all (simple fix)
Summary: sawfish menus do not work at all (simple fix)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rep-gtk (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Tammy Fox
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-06 01:04 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 22:40:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Berkenbilt 2002-08-06 01:04:09 UTC
Description of Problem:

In sawfish as present in limbo 2, menus do not work at all.

Version-Release number of selected component (if applicable):

sawfish-1.9.0-3
rep-gtk-0.16.0.90-3
librep-0.15.2.91-3

How Reproducible:

always

Steps to Reproduce:
1. start sawfish
2. attempt to invoke a menu

Actual Results:

no menu appears

Expected Results:

a menu should appear

Additional Information:
	
The problem is that the "gui" directory in the rep-gtk installation appears in
/usr/libexec/rep/i386-redhat-linux-gnu instead of
/usr/libexec/rep/i386-redhat-linux.  (Or, the problem is that the former
directory is not in dl-load-path.)

Moving the gui directory from /usr/libexec/rep/i386-redhat-linux-gnu to
/usr/libexec/rep/i386-redhat-linux solves the problem.

I've set the severity of this bug to "high" because it renders sawfish largely
unusable and has a trivial fix.

Gratuitous commment: I've been using sawfish (or sawmill) since before it was
RedHat's default and will continue to use it now that it is (sadly) no longer
the default.  I'm glad it's still present in the distribution.  I hope it stays.
 It offers functionality (through its lisp interface) that no other modern
window manager can provide.

Comment 1 Jay Berkenbilt 2002-08-06 01:45:09 UTC
I apologize for the noise on this bug.  I accidentally selected the wrong
component when I posted the bug thus causing botched assignments.  I hope I've
fixed it by selecting "Assign but to owner of selected component".

Comment 2 Jay Berkenbilt 2002-08-06 01:55:07 UTC
Oops.  On the version of bugzilla I use (2.16), when a poster changes an
assignee, the status reverts back to NEW rather than going straight to assigned.
 If I don't see anything happen on this, I'll kill it and repost.  Again, sorry
for the noise here.  I just tend to be very anal during beta periods so that I
can enjoy releases that work perfectly for all my needs. :-)

Comment 3 Havoc Pennington 2002-08-06 20:34:33 UTC
Have you tried rep-gtk-0.16.0.90-4 from Rawhide?

Comment 4 Jay Berkenbilt 2002-08-07 22:40:07 UTC
With these versions from rawhide:

rep-gtk-0.16.0.90-4
librep-0.16-1
sawfish-2.0-1

this problem is corrected.  The dependencies are such that you can upgrade
rep-gtk and librep without upgrading sawfish and then get a partially paralyzed
sawfish, but I suppose there's not much that can be done about that.  Upgrading
all three packages does solve this problem without introducing any new ones that
I've found so far.  Thanks.  Presumably this will be in the next beta, release,
or up2date....

Comment 5 Havoc Pennington 2002-08-14 02:16:47 UTC
thanks, closing.


Note You need to log in before you can comment on or make changes to this bug.