Bug 70845 - release notes suggestions
release notes suggestions
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-05 21:32 EDT by Jay Berkenbilt
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 19:32:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2002-08-05 21:32:11 EDT
I have several suggestions about the release notes.

Tkinter has disappeared. Tk is not installed by default.  I believe these are
significant changes that need to be documented in the release notes.  I have
several applications that don't work anymore because of this.  (I am reporting
this separately as a bug.)

Some of the things that appeared in the release announcement such as gcc
defaulting to gcc 3.2 should be in the release notes.  There are very important
differences between older gcc releases and 3.1/3.2.  I'd suggest that someone
review the high points of the new release mentioned in the release announcement
and make sure that they are also mentioned in the release notes.

/usr/bin/python is now python 2.2.  I think this is a very significant change
and deserves special mention.  I think this, like gcc 3.2 and perl 5.8, deserves
mention directly in the release announcement itself.

There seemed to be some unprintable characters in the release notes as displayed
during installation.  I'm sorry that I can't reproduce this.  I saw, among other
things, a glyph that was approximately

+---+
|0 0|
|0 7|
+---+

where a "g" should have been.  This character reminds me of what uniprint (?)
generates when it finds a non-renderable Unicode value.  This would be the value
for CTRL-g.  I couldn't find any instances of CTRL-g in the RELEASE-NOTES file
on disc1.  I don't know what the source of the release notes file displayed
during installation is, however.  I'm sure it isn't that fle, though!
Comment 1 Jeremy Katz 2002-08-06 03:50:13 EDT
The unprintable characters has to do with the release notes not being properly
utf8-ified... there's another bug about that and msw is working on it. 
Assigning to John for the various suggestions for additions
Comment 2 Jay Berkenbilt 2002-08-08 13:14:18 EDT
As per bug 70896, Tkinter will be in the next release after all.  There
definitely seems to be a wave of sentiment against keeping it around much
longer, though.  If the decision to restore Tkinter is temporary and it will be
pulled in a future release, I'd like to suggest that the intention to deprecate
Tk and Tkinter be mentioned clearly in the release notes.  That will give people
time to migrate their existing Tk/Tkinter infrastructure to something new in
time for the first RedHat release (presumably 9) that doesn't include Tk/Tkinter.

I still think that Tk and Tkinter should not be deprecated, but if they are
going to be, let's not have the decision be made silently.  A lot of code out
there uses these packages.  Even if there are good alternatives on Linux and on
RedHat Linux in particular, there are other considerations.  I've stated my case
in bug 70896 though, so I won't repeat it here.
Comment 3 John Ha 2002-08-12 19:32:37 EDT
Thank you for your suggestions. We are adding entries and bulleted feature lists
for the packages you mentioned and will be outlining new features for other 
major packages as well. 

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.