Bug 70852 - traceback, AttributeError: setVerifySigFlags
traceback, AttributeError: setVerifySigFlags
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 00:45 EDT by Michael Schwendt
Modified: 2015-01-07 18:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 12:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-08-06 00:45:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Made the mistake to upgrade "up2date-*", "rhnlib", and "rpm" before getting the
first several hundred updates for Limbo beta2. up2date 2.9.33 fails to run:

# up2date
creating readOnlyTransaction
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 18, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth 
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 221, in ?
    rpm_version = getRpmVersion()
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 210, in getRpmVersion
    ts = transaction.initReadOnlyTransaction()
  File "/usr/share/rhn/up2date_client/transaction.py", line 25, in
initReadOnlyTransaction
    read_ts.setVerifySigFlags(8)
AttributeError: setVerifySigFlags


How reproducible:
Always


Version-Release number of selected component (if applicable):

# rpm -qa | egrep '^(rpm)|(up2date)|(rhn)'
up2date-2.9.33-7.x.9
rpm404-python-4.0.4-8x.26
rpm-build-4.1-0.57
rpm-4.1-0.69
rpmdb-redhat-7.3.93-0.20020726
rhnlib-0.8-13
up2date-gnome-2.9.33-7.x.9
rpm-python-4.1-0.57
Comment 1 Michael Schwendt 2002-08-06 00:52:28 EDT
Dependencies are wrong. up2date 2.9.33-7.x.9 must require:

rpm-python >= 4.1-0.69
Comment 2 Michael Schwendt 2002-08-06 00:55:49 EDT
With rpm-python upgraded, I'm getting further. But after "Testing dependencies",
up2date-gnome terminates all of a sudden. No further output:

# up2date
creating readOnlyTransaction

** (up2date:3368): WARNING **: could not find handler `onRegPackagePageBack'
Comment 3 Michael Schwendt 2002-08-06 01:03:22 EDT
The step where up2date-gnome 2.9.33 terminates is after a few seconds at 0% of
the dialog:
-----
Registration Progress

Testing package set / solving RPM inter-dependencies
------
up2date-gnome 2.9.31 does lengthy calculations there, but proceeds flawlessly,
also with the upgraded RPM (0.69) packages.
Comment 4 Adrian Likins 2002-08-06 16:02:34 EDT
should be fixed in a future release, those particular versions
are a little off kilter as they are the first versions using
rpm-4.1
Comment 5 Adrian Likins 2002-08-07 16:47:08 EDT
also, rpm changed the name of the call at some point,
so some versions are mismatched
Comment 6 Carsten Clementschitsch 2002-08-12 11:59:01 EDT
Still there in version 2.9.39

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 18, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 11, in ?
    import up2dateUtils
  File "/usr/share/rhn/up2date_client/up2dateUtils.py", line 15, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 28, in ?
    import gpgUtils
  File "/usr/share/rhn/up2date_client/gpgUtils.py", line 17, in ?
    _ts = transaction.initReadOnlyTransaction()
  File "/usr/share/rhn/up2date_client/transaction.py", line 65, in
initReadOnlyTransaction
    read_ts.pushVSFlags(8)
  File "/usr/share/rhn/up2date_client/transaction.py", line 54, in pushVSFlags
    self.ts.setVSFlags(self.tsflags[-1])
AttributeError: setVSFlags
Comment 7 Michael Schwendt 2002-08-12 12:10:30 EDT
Apparently, RPM's API keeps changing, and the u2pdate packages still does not
depend on specific versions of rpm-python. But it ought to. Because that is the
idea of package dependencies.
Comment 8 Adrian Likins 2002-08-22 17:35:28 EDT
current versions of up2date require at least
a specific version of rpm. 

I'm not going to make it depend on exactly a specific version,
as that just causes more problems. The API
should be stable once things are finalized.

Note You need to log in before you can comment on or make changes to this bug.