Bug 708533 - fails to build without downstream patches
fails to build without downstream patches
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-apps (Show other bugs)
6.1
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 17:25 EDT by Kamil Dudka
Modified: 2014-07-15 06:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-15 06:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (835 bytes, patch)
2011-05-27 17:26 EDT, Kamil Dudka
no flags Details | Diff

  None (edit)
Description Kamil Dudka 2011-05-27 17:25:24 EDT
Version-Release number of selected component (if applicable):
xorg-x11-apps-7.4-10.el6


Steps to Reproduce:
1. rpmbuild --define '__patch /bin/true' --rebuild xorg-x11-apps-7.4-10.el6.src.rpm

  
Actual results:
DEBUG: configure: WARNING: unrecognized options: --disable-xprint
DEBUG: + make
DEBUG: make  all-am
DEBUG: make[1]: Entering directory `/builddir/build/BUILD/xorg-x11-apps-7.4/xconsole-1.0.3'
DEBUG: gcc -DHAVE_CONFIG_H -I.     -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -M
DEBUG: xconsole.c:185:45: error: sys/stropts.h: No such file or directory
DEBUG: xconsole.c: In function 'get_pty':
DEBUG: xconsole.c:838: warning: implicit declaration of function 'openpty'
DEBUG: make[1]: Leaving directory `/builddir/build/BUILD/xorg-x11-apps-7.4/xconsole-1.0.3'
DEBUG: make[1]: *** [xconsole.o] Error 1
DEBUG: make: *** [all] Error 2
DEBUG: RPM build errors:
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.AuIZTY (%build)
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.AuIZTY (%build)


Additional info:
The proposed change is required for Coverity to scan defects in downstream
patches separately.
Comment 1 Kamil Dudka 2011-05-27 17:26:46 EDT
Created attachment 501402 [details]
proposed fix
Comment 4 Suzanne Yeghiayan 2012-02-14 18:09:51 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Hans de Goede 2014-07-15 05:12:50 EDT
Patch looks good to me, and "The proposed change is required for Coverity to scan defects in downstream patches separately." seems like a good reason to me to add it.
Comment 7 Kamil Dudka 2014-07-15 05:39:19 EDT
I tried xorg-x11-apps-7.7-6.el6 and the package builds fine without downstream patches, so I believe this bug can be closed as fixed.
Comment 8 Hans de Goede 2014-07-15 06:35:24 EDT
(In reply to Kamil Dudka from comment #7)
> I tried xorg-x11-apps-7.7-6.el6 and the package builds fine without
> downstream patches, so I believe this bug can be closed as fixed.

Great, thanks! Closing.

Note You need to log in before you can comment on or make changes to this bug.