Bug 70858 - xmms does not save options or state
xmms does not save options or state
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: xmms (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 01:51 EDT by Gary Peck
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 17:25:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Peck 2002-08-06 01:51:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
When I change any of xmms' options or change its state (e.g. toggle shuffle
mode), exit xmms, and then start it again, the option/state reverts back to its
old value. This includes options in the "Options" tab of xmms, switching skins,
toggling shuffle mode, toggling the  windowshade status of a window, and the
position in the playlist.

If I look in .xmms/config after exiting xmms, the old value is still in there.
If I then edit .xmms/config manually and restart xmms, it sees the new value.

Version-Release number of selected component (if applicable):
xmms-1.2.7-9

How reproducible:
Always

Steps to Reproduce:
1. Start xmms
2. Toggle shuffle mode on
3. Exit xmms (by clicking on the X in the corner)
4. Start xmms again


Actual Results:  Shuffle mode was turned off.

Expected Results:  Shuffle mode should have been on.

Additional info:
Comment 1 Gary Peck 2002-08-08 17:25:23 EDT
Never mind. I thought the bug was a result of upgrading to rawhide xmms, but it
turns out to be an interaction between xmms and a plugin I installed at around
the same time. Removing the plugin fixed the problem. Will follow it up with the
xmms developers.

I'm going to change the bug state to NEEDINFO, or should it be CLOSED?

Note You need to log in before you can comment on or make changes to this bug.