Bug 70859 - finishes downloading with total progress at %91
finishes downloading with total progress at %91
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 02:37 EDT by Michael Schwendt
Modified: 2015-01-07 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 22:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot to prove this (26.68 KB, image/png)
2002-08-06 02:37 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2002-08-06 02:37:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
This is something I've reported before with an older version of the distribution
(something with "total progess" ending at 99%, but I'm unable to find the bug
number).

Problem scenario is as follows:

Run "up2date", let it download a couple of packages. Click "Cancel" to interrupt
the process. Restart "up2date". It will see the already downloaded packages
(e.g. kernel, kernel-doc), not download them again, and continue downloading the
remainding packages.

At 91% total progress, I see this assertion warning for every package,

(up2date:3483): Gtk-CRITICAL **: file gtkprogress.c: line 550
(gtk_progress_set_percentage): assertion `percentage >= 0 && percentage <= 1.0'
failed

and the "Total progress" bar stays at 91%. Additionally, with the last package
downloaded (in my case, xmms-skins-1.2.7-9.i386.rpm), and total progress still
at %91, up2date-gnome reads: All finished. Click "Forward" to continue.

See attached screenshot.

At that point I clicked "Cancel" this time to test what I would get upon running
it again and all packages found downloaded already in the spool dir. It started
with total progress 100% and "Package already downloaded" for each package.


Version-Release number of selected component (if applicable):
up2date-gnome-2.9.31-7.x.9

How reproducible:
Didn't try

However, with this happening again in Limbo beta2, I consider it proven that
there is a bug related to calculation of "total progress" percentage. It must be
related to picking up already downloaded packages.
Comment 1 Michael Schwendt 2002-08-06 02:37:56 EDT
Created attachment 69024 [details]
screenshot to prove this
Comment 2 Adrian Likins 2002-08-08 22:37:26 EDT
will take a look
Comment 3 Adrian Likins 2002-08-22 17:31:43 EDT
believe this is fixed in current versions (say 2.9.50 or newer)

Looks like a roudoff error was causing broken progress percentages
to get passed to gtk, which just refused to update for those
weird cases

Note You need to log in before you can comment on or make changes to this bug.