Bug 708624 - No network available after upgrading
No network available after upgrading
Status: CLOSED DUPLICATE of bug 708445
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 08:37 EDT by antonio montagnani
Modified: 2011-05-30 16:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 16:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2011-05-28 08:37:09 EDT
Description of problem:
After upgrading to latest I had no network (wired/wireless) available

Version-Release number of selected component (if applicable):
NetworkManager-0.8.999-3.git20110526.fc15

How reproducible:
always

Steps to Reproduce:
1.just upgrade
2.
3.
  
Actual results:
No network

Expected results:
available networks

Additional info:
Comment 1 antonio montagnani 2011-05-28 11:54:43 EDT
My smolt profile is here:

http://www.smolts.org/client/show/pub_c38b5c49-9c83-4457-8db8-03d91072afa6
Comment 2 antonio montagnani 2011-05-28 13:14:05 EDT
FYI information this is the log of latest updates

May 28 07:09:15 Updated: 2:gimp-libs-2.6.11-14.fc15.i686
May 28 07:09:28 Updated: 2:gimp-2.6.11-14.fc15.i686
May 28 07:09:29 Updated: 2:gimp-help-browser-2.6.11-14.fc15.i686
May 28 07:11:50 Updated: ibus-libs-1.3.99.20110408-5.fc15.i686
May 28 07:11:51 Updated: ibus-gtk2-1.3.99.20110408-5.fc15.i686
May 28 07:11:52 Updated: ibus-gtk3-1.3.99.20110408-5.fc15.i686
May 28 07:12:09 Updated: ibus-1.3.99.20110408-5.fc15.i686
May 28 07:12:10 Updated: 1:NetworkManager-glib-0.8.999-3.git20110526.fc15.i686
May 28 07:12:13 Updated: 1:NetworkManager-0.8.999-3.git20110526.fc15.i686
May 28 07:12:20 Updated: mutter-3.0.2.1-1.fc15.i686
May 28 07:12:27 Updated: gnome-shell-3.0.2-1.fc15.i686
May 28 07:12:34 Updated: 1:NetworkManager-gnome-0.8.999-3.git20110526.fc15.i686
May 28 07:12:36 Updated: ibus-hangul-1.3.1-3.fc15.i686
May 28 07:12:40 Updated: gdb-7.2.90.20110525-38.fc15.i686
May 28 07:12:45 Updated: rhythmbox-2.90.1-10.git20110502.fc15.i686

afterwards, the computer worked flawlessly until I rebooted it - it was lunch time :-)
When I rebooted no network were available, so I decided to downgrade the three Network Manager files, rebooted and everything was back working, after I had to re-enter WPA passwords for wireless connection that were destroyed
Comment 3 antonio montagnani 2011-05-28 17:42:23 EDT
forgot to say that I get the warning that network services are not compatible with this version...

No idea what does it mean
Comment 4 Alessandro Nazzani 2011-05-29 04:14:57 EDT
I just had the exact same problem. :(

Grazie Antonio for posting a workaround!

Alessandro
Comment 5 Jussi Torhonen 2011-05-29 10:29:18 EDT
Same problem here after upgrading NetworkManager packages with you on Sun 29 May. Actually things worked ok, until I created a new VPN profile using nm-connection-editor. Tried importing a Cisco VPN profile file (pcf) and got some error. Logged out, logged in and all I got matched to the following page, that actually gives excellent workaround:

http://www.surfer07.be/fedora/

But if I really need that Cisco vpnc profile under NetworkManager, how can I get it there working?
Comment 6 Jussi Torhonen 2011-05-29 10:50:36 EDT
The same problem happens, when creating a new VPN profile via Gnome3 System Settings - Network - '+' - VPN - Cisco Compatible VPN (vpnc) - etc and even cleaned that 'Available to all users' option. Anyway that wizard created profile file under /etc/NetworkManager/system-connections/ even the wizard died with an error message. If logging out/in, cannot use network at all. Removing that new profile from the directory above, logging out/in, I worked again.

I have one another laptop updated from F14 to F15. It had my vpnc profile there before the update. In that laptop I can use that existing VPN profile with NetworkManager without any problems.

Hope this helps finding the root cause to this problem.
Comment 7 antonio montagnani 2011-05-29 11:02:36 EDT
Jussi,

do you mean that any configuration file in /etc/NetworkManager/system-connections/ would cause such troubles??

I checked and actually I have a configuration file coming from Internet wireless connection.

I will wait for a fast upgrade (and I suppose that any user with special connection would suffer of this bug)
Comment 8 Jussi Torhonen 2011-05-29 11:25:24 EDT
I have update two laptops from F14 to F15. Both do have wired ethernet and wireless network connection under NetworkManager. No profile file found in that directory. It looks like the related network configuration is found as /etc/sysconfig/network-scripts/ifcfg-*

My 1st laptop did not have any profiles under that directory. Updated to F15 and on 29 May updated NM packages with yum.

In my 2nd laptop I created VPN profile as well as a 3G broadband profile when running F14. After updated to F15 and even updated those NM packages, I still can see those profiles in the directory. Just tried VPN and it works beautifully.

So, you cannot say that if any profiles are found in the directory, NM would not work ever. As seen, it works ok if the profiles were there before updating from F14 to F15.
Comment 9 Alessandro Nazzani 2011-05-29 11:38:05 EDT
I have a VPN connection under /etc/NetworkManager/system-connections as well (I think I never used it in F15, might be something ported from the previous F13 install).

I'll wait for a comment from RedHat staff before trying anything else; if you need more info, just ask. ;)

Alessandro
Comment 10 Evan Carroll 2011-05-29 18:24:38 EDT
I'm also having this problem. I don't have anything under /etc/NetworkManager/system-connections. This bug report fits me perfectly too. Problem occurred today after update on FC15.

Also, Buzilla really blows. Seriously, migrate to Launchpad: when Canonical does everything better, follow. This thing took 10 minutes to get my "sign up" e-mail to my gmail account.
Comment 11 Evan Carroll 2011-05-29 18:32:11 EDT
I can confirm too, that you can get NetworkManager to start just by removing the plugin line in /etc/NetworkManager/NetworkManager.conf . However, you no longer have the configuration information available to connect to the wireless services.
Comment 12 Evan Carroll 2011-05-30 11:21:59 EDT
If I look into /var/log/messages I get this 


May 30 10:20:42 x200s NetworkManager[5506]: <info> NetworkManager (version 0.8.999-3.git20110526.fc15) is starting...
May 30 10:20:42 x200s NetworkManager[5506]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
May 30 10:20:42 x200s NetworkManager[5506]: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
May 30 10:20:42 x200s NetworkManager[5506]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_CafeExpress-Wifi ... 
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh:     read connection 'Auto CafeExpress-Wifi'
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_linksys 1 ... 
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh:     read connection 'Auto linksys'
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_WCSCNET-2.4G ... 
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh:     read connection 'Auto WCSCNET-2.4G'
May 30 10:20:42 x200s NetworkManager[5506]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_EvanCarroll ... 
May 30 10:20:42 x200s NetworkManager[5506]: <warn> caught signal 11. Generating backtrace...
May 30 10:20:42 x200s NetworkManager: ******************* START **********************************
May 30 10:20:42 x200s NetworkManager: [Thread debugging using libthread_db enabled]
May 30 10:20:42 x200s NetworkManager: 0x00d8c416 in __kernel_vsyscall ()
May 30 10:20:42 x200s NetworkManager: #0  0x00d8c416 in __kernel_vsyscall ()
May 30 10:20:42 x200s NetworkManager: #1  0x4b25c5a3 in __waitpid_nocancel () from /lib/libpthread.so.0
May 30 10:20:42 x200s NetworkManager: #2  0x080a4b65 in nm_logging_backtrace ()
May 30 10:20:42 x200s NetworkManager: #3  0x0808a21d in ?? ()
May 30 10:20:42 x200s NetworkManager: #4  <signal handler called>
May 30 10:20:42 x200s NetworkManager: #5  0x4b3110d2 in g_hash_table_iter_next () from /lib/libglib-2.0.so.0
May 30 10:20:42 x200s NetworkManager: #6  0x080d3340 in ?? ()
May 30 10:20:42 x200s NetworkManager: #7  0x080d4fd1 in nm_settings_connection_replace_settings ()
May 30 10:20:42 x200s NetworkManager: #8  0x0017ba67 in nm_ifcfg_connection_new () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: #9  0x00179f14 in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: #10 0x0017a57e in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: #11 0x0017a796 in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: #12 0x080d2e50 in nm_system_config_interface_get_unmanaged_specs ()
May 30 10:20:42 x200s NetworkManager: #13 0x080cf470 in ?? ()
May 30 10:20:42 x200s NetworkManager: #14 0x080d2158 in nm_settings_new ()
May 30 10:20:42 x200s NetworkManager: #15 0x08060e14 in main ()
May 30 10:20:42 x200s NetworkManager: 
May 30 10:20:42 x200s NetworkManager: Thread 1 (Thread 0xb7807750 (LWP 5506)):
May 30 10:20:42 x200s NetworkManager: #0  0x00d8c416 in __kernel_vsyscall ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #1  0x4b25c5a3 in __waitpid_nocancel () from /lib/libpthread.so.0
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #2  0x080a4b65 in nm_logging_backtrace ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #3  0x0808a21d in ?? ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #4  <signal handler called>
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #5  0x4b3110d2 in g_hash_table_iter_next () from /lib/libglib-2.0.so.0
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #6  0x080d3340 in ?? ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #7  0x080d4fd1 in nm_settings_connection_replace_settings ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #8  0x0017ba67 in nm_ifcfg_connection_new () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #9  0x00179f14 in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #10 0x0017a57e in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #11 0x0017a796 in ?? () from /usr/lib/NetworkManager/libnm-settings-plugin-ifcfg-rh.so
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #12 0x080d2e50 in nm_system_config_interface_get_unmanaged_specs ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #13 0x080cf470 in ?? ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #14 0x080d2158 in nm_settings_new ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: #15 0x08060e14 in main ()
May 30 10:20:42 x200s NetworkManager: No symbol table info available.
May 30 10:20:42 x200s NetworkManager: A debugging session is active.
May 30 10:20:42 x200s NetworkManager: 
May 30 10:20:42 x200s NetworkManager: #011Inferior 1 [process 5506] will be detached.
May 30 10:20:42 x200s NetworkManager: 
May 30 10:20:42 x200s NetworkManager: Quit anyway? (y or n) [answered Y; input not from terminal]
May 30 10:20:42 x200s NetworkManager: ******************* END **********************************
Comment 13 Evan Carroll 2011-05-30 11:38:56 EDT
I was also able to get NetworkManager to start back up by deleting all of the ifcfg-* files in 

rm /etc/sysconfig/network-scripts/ifcfg-*
Comment 14 Jirka Klimes 2011-05-30 16:19:37 EDT

*** This bug has been marked as a duplicate of bug 708445 ***

Note You need to log in before you can comment on or make changes to this bug.