This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 708626 - NetworkManager crashes at startup.
NetworkManager crashes at startup.
Status: CLOSED DUPLICATE of bug 708445
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 08:46 EDT by Chris Rankin
Modified: 2011-05-30 16:10 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 16:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace that was dumped into /var/log/messages (7.27 KB, text/plain)
2011-05-28 08:51 EDT, Chris Rankin
no flags Details
ifcfg file that "kills" NM (211 bytes, text/plain)
2011-05-28 08:53 EDT, Chris Rankin
no flags Details
/var/log/messages backtrace info - mihailim (9.66 KB, text/plain)
2011-05-28 13:22 EDT, Mihai Limbășan
no flags Details
/etc/NetworkManager/system-connections VPN definition - mihailim (389 bytes, text/plain)
2011-05-28 13:23 EDT, Mihai Limbășan
no flags Details

  None (edit)
Description Chris Rankin 2011-05-28 08:46:24 EDT
Description of problem:
NetworkManager crashes when trying to read ifcfg scripts.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.999-3.git20110526.fc15.i686.rpm   

How reproducible:
Always.

Steps to Reproduce:
1. /etc/init.d/NetworkManager start
  
Actual results:
BANG!

Expected results:
My network.

Additional info:
Downgrading to NetworkManager-0.8.999-2.git20110509.fc15.i686.rpm fixes it.
Comment 1 Chris Rankin 2011-05-28 08:51:53 EDT
Created attachment 501470 [details]
backtrace that was dumped into /var/log/messages

Ignore the "Invalid WEP key" message for ifcfg-wlan0, because the working downgraded version says that too.
Comment 2 Chris Rankin 2011-05-28 08:53:57 EDT
Created attachment 501471 [details]
ifcfg file that "kills" NM
Comment 3 Mihai Limbășan 2011-05-28 13:14:40 EDT
Confirmed bug on F15 i686 stable repositories + RPMFusion stable, confirmed fix is downgrade. Dear $deity, the Fedora NM situation is a mess (doubly so for KDE users...)
Comment 4 Mihai Limbășan 2011-05-28 13:21:52 EDT
In my case it was croaking on a PPTP VPN definition in /etc/NetworkManager/system-connections (stuck in endless service restart cycle). VPN definition file  and /var/log/messages backtrace output attached, sensitive info replaced with the text REDACTED-BUT-VALID.
Comment 5 Mihai Limbășan 2011-05-28 13:22:44 EDT
Created attachment 501502 [details]
/var/log/messages backtrace info - mihailim
Comment 6 Mihai Limbășan 2011-05-28 13:23:22 EDT
Created attachment 501503 [details]
/etc/NetworkManager/system-connections VPN definition - mihailim
Comment 7 Jean-François Fortin Tam 2011-05-28 14:38:18 EDT
Possible duplicate of bug 708445 ?
In my case it wasn't choking on VPN connections but on the wired and wireless networks in /etc/sysconfig/network-scripts
Comment 8 Mihai Limbășan 2011-05-28 14:49:15 EDT
Yup, thanks, Jean-François, my testcase is clearly #708445 , please ignore my comments on this bug. Obsoleting attachments.
Comment 9 Jeff Guerdat 2011-05-28 18:21:55 EDT
Confirmed on my laptop.  Upgrade broke NM, downgrade works fine.
Comment 10 Gilboa Davara 2011-05-29 04:40:59 EDT
Confirmed.
Download solves the problem.
Comment 11 Andrew Haveland-Robinson 2011-05-29 04:59:31 EDT
This hurt me too on an HP530 laptop completely destroying wifi connectivity at
my cafe until I could get back home to a wired network and issue an "ifup eth0"
command. The error "code=exited, status=1/FAILURE" reported by "service
NetworkManager restart" wasn't very helpful.

The real error seemed to be hiding in messages:
dbus-daemon: [system] Failed to activate service
'org.freedesktop.NetworkManager': timed out 
With this
ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_Linksys-guest ...
<warn> caught signal 11. Generating backtrace...

ESSID="Linksys-guest"
MODE=Managed
TYPE=Wireless
BOOTPROTO=dhcp
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=yes
NAME="Auto Linksys-guest"
UUID=4d02ebf8-f969-4167-b427-b797ac7174ef
ONBOOT=yes
USERS=user

This was the first ifcfg file in an unsorted dir "ls -f" and typical.

yum downgrade should work, but I got dependency errors.

I solved it thus:
~ # rpm -e --nodeps NetworkManager-glib-0.8.999-3.git20110526.fc15.i686
~ # rpm -e --nodeps NetworkManager-gnome-0.8.999-3.git20110526.fc15.i686
~ # rpm -e --nodeps NetworkManager-0.8.999-3.git20110526.fc15.i686

~ # yum install NetworkManager-glib-0.8.999-2.git20110509.fc15.i686
NetworkManager-gnome-0.8.999-2.git20110509.fc15.i686
NetworkManager-0.8.999-2.git20110509.fc15.i686

~ # yum check

yum and rpm still have naming inconsistences making it tedious to copy and
paste package names between query results and commands.

When can we finally get a yum download and yum remove --nodeps command?
Comment 12 Oron Peled 2011-05-29 10:35:28 EDT
yum downgrade restores a working version. To avoid dependency problems:
  yum downgrade NetworkManager{,-gnome,-glib}
Comment 13 Kevin Kofler 2011-05-29 13:21:36 EDT
> Dear $deity, the Fedora NM situation is a mess (doubly so for KDE users...)

Well, the update which caused this regression fixes the issues we had with kde-plasma-networkmanagement (VPN was broken), which is why it ended up in stable so quickly. (It got a karma of +3 before even reaching testing (but the 3rd +1 came while the push was already underway, so it landed in testing anyway) and was already at +6 when it landed in stable.)
Comment 14 Mihai Limbășan 2011-05-29 13:29:28 EDT
Unfortunately, since it chokes on VPN connection definitions, it doesn't fix these issues at all...

I know Bugzilla's not hte place to vent, and I know this has been rehashed about seventeen hundred times already - but I wasn't referring to this particular instance of a bug with the above (I'm perfectly capable of working around bugs), I was referring to the entire NetworkManager situation is Fedora. I truly believe that it would have been better to delay by another two weeks instead of inflicting such a mess in a fundamental system component on the users :(

Ah well. </rant>
Comment 15 Kevin Kofler 2011-05-29 13:37:16 EDT
> Unfortunately, since it chokes on VPN connection definitions, it doesn't fix
> these issues at all...

It chokes on systemwide VPN connection definitions (and some systemwide ifcfg definitions, too, which is what this bug is about). The current kde-plasma-networkmanagement in F15 doesn't support system connections at all. So this does not affect kde-plasma-networkmanagement. At least 3 people tested this with kde-plasma-networkmanagement and found it to fix their VPN, and 3 more people tested the NM update with no regressions (but apparently either did not have system connections at all or their system connections did not trigger the patch).
Comment 16 Kevin Kofler 2011-05-29 13:37:54 EDT
Oops, I mean:
… or their system connections did not trigger the BUG).
Comment 17 Mihai Limbășan 2011-05-29 15:02:49 EDT
> It chokes on systemwide VPN connection definitions (and some systemwide ifcfg
definitions, too, which is what this bug is about).

Ahh... That aspect didn't occur to me. Thanks, will test moving the definitions to a user profile and return with the results.
Comment 18 Kevin Kofler 2011-05-29 16:05:11 EDT
Making them per-user inside NetworkManager won't help; for kde-plasma-networkmanagement to see the connections, they have to be set up within kde-plasma-networkmanagement in its internal storage.

Normally, all NetworkManager 0.9 clients should be storing all connections in systemwide storage (even per user ones), but kde-plasma-networkmanagement still uses a compatibility interface which allows passing connections internal to kde-plasma-networkmanagement to NetworkManager.
Comment 19 Mary Ellen Foster 2011-05-30 07:16:32 EDT
Also seeing this on two separate F15 laptops. Both have Enterprise WPA networks in their NM config if that's relevant.
Comment 20 Jirka Klimes 2011-05-30 16:10:34 EDT

*** This bug has been marked as a duplicate of bug 708445 ***

Note You need to log in before you can comment on or make changes to this bug.