Bug 708635 - AttributeError: 'PPDsLoader' object has no attribute '_devid_dict'
Summary: AttributeError: 'PPDsLoader' object has no attribute '_devid_dict'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 711908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-28 13:58 UTC by John Reiser
Modified: 2011-06-21 17:13 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.3.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-21 17:13:22 UTC
Type: ---


Attachments (Terms of Use)

Description John Reiser 2011-05-28 13:58:02 UTC
Description of problem: system-config-printer hangs "Searching for drivers"


Version-Release number of selected component (if applicable):
system-config-printer-1.3.2-2.fc15.x86_64


How reproducible: every time


Steps to Reproduce:
1. # system-config-printer   ### as superuser (root)
2. unlock, add, Find network printer, allow firewall modification, give hostname that has printer, Next
3.
  
Actual results:
-----console log
(system-config-printer.py:3204): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:3204): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:3204): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/share/system-config-printer/asyncipp.py", line 197, in send_reply
    handler (self._conn, result)
  File "/usr/share/system-config-printer/asyncconn.py", line 93, in reply_handler
    self._reply_handler (self, self._reply_data, *args)
  File "/usr/share/system-config-printer/asyncconn.py", line 204, in _subst_reply_handler
    reply_handler (self, *args)
  File "/usr/share/system-config-printer/ppdsloader.py", line 159, in _cups_reply
    getPPDNamesFromDeviceID (self._devid_dict["MFG"],
AttributeError: 'PPDsLoader' object has no attribute '_devid_dict'
-----end console log

and main graphics dialog "Searching for drivers" does not respond to clicks on its Cancel button.

Expected results: success


Additional info:

Comment 1 Jiri Popelka 2011-05-30 10:22:04 UTC
You shouldn't run system-config-printer as superuser.
Is it reproducible when you run it as ordinary user ?

Comment 2 Tim Waugh 2011-05-31 10:46:59 UTC
Same as bug #693515 I think but for 1.3.x.  Already fixed upstream (9221eb4).

Comment 3 John Reiser 2011-05-31 18:32:40 UTC
(In reply to comment #1)
> You shouldn't run system-config-printer as superuser.
Then s-c-p must detect this, and complain with an appropriate message.

> Is it reproducible when you run it as ordinary user ?
I cannot reproduce the traceback as an ordinary user.

Comment 4 Fedora Update System 2011-06-03 11:35:05 UTC
system-config-printer-1.3.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.3-1.fc15

Comment 5 Fedora Update System 2011-06-04 03:04:36 UTC
Package system-config-printer-1.3.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.3-1.fc15
then log in and leave karma (feedback).

Comment 6 Jiri Popelka 2011-06-09 08:45:39 UTC
*** Bug 711908 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-06-21 17:12:47 UTC
system-config-printer-1.3.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.