Bug 70864 - libtoolize doesn't put ltmain.sh in CONFIG_AUX_DIR
Summary: libtoolize doesn't put ltmain.sh in CONFIG_AUX_DIR
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: libtool   
(Show other bugs)
Version: limbo
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-06 08:45 UTC by bastiaan
Modified: 2015-01-07 23:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 08:46:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bastiaan 2002-08-06 08:45:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
If one uses 'configure.ac' rather than the old name 'configure.in', libtoolize
will not find the correct CONFIG_AUX_DIR.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Write a configure.ac with AC_CONFIG_AUX_DIR(somedir)
2.run libtoolize
3.ls and ls somedir 
	

Actual Results:  ltmain.sh has been put in . instead of in 'somedir' 

Expected Results:  ltmain.sh should have been put in CONFIG_AUX_DIR 'somedir'

Additional info:

The bug is caused by using the hardcoded name 'confiure.in' instead of
$configure_ac in libtoolize.

The bug has been fix in libtools CVS, see:
http://subversions.gnu.org/cgi-bin/cvsweb/libtool/libtoolize.in.diff?r1=1.15.2.1&r2=1.15.2.2

for the actual patch.

PS. this problem is in RH7.3 and earlier too.

Comment 1 Jens Petersen 2002-08-14 03:57:37 UTC
Thanks for the report.

Should be fixed in libtool-1.4.2-11.


Note You need to log in before you can comment on or make changes to this bug.