Bug 708667 - Unmaximize does not work
Unmaximize does not work
Status: CLOSED DUPLICATE of bug 693156
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
15
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 14:41 EDT by Luis A. Florit
Modified: 2011-05-28 15:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-28 15:01:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luis A. Florit 2011-05-28 14:41:19 EDT
Description of problem:

Although fullscreen funcion works, unfullscreen function does not, both with the window top-right button and keyboard shortcut. The top-right button changes the state, but window preserves size.

This affects both xterm and rxvt. All other window applications work fine.

kdebase-4.6.3-1.fc15.i686
xterm-268-1.fc15.i686
rxvt-2.7.10-20.fc15.i686
Comment 1 Luis A. Florit 2011-05-28 14:43:28 EDT
Sorry, by fullscree/unfullscreen I meant maximize/unmaximize.
Comment 2 Luis A. Florit 2011-05-28 15:01:06 EDT
Ooops... this bug is duplicated, sorry. I searched for unfullscreen instead of unmaximize. Anyway, this workaround worked for me too:

https://bugs.kde.org/show_bug.cgi?id=272886#c1

In KDE, go to Menu > System Settings > Window Behavior > Window Rules
Then:

   * Click on "New".
   * Click the "Detect Window Properties" button.
   * Click on an xterm.
   * Select "Use window class (whole application)".
   * Click "Ok".
   * Click on the "Workarounds" tab.
   * Select "Strictly obey geometry", change drop-down to "Force" and leave the
final check-box un-checked.
   * Click "Ok"
   * Click "Apply".

Worked for me.
L.

*** This bug has been marked as a duplicate of bug 693156 ***

Note You need to log in before you can comment on or make changes to this bug.