Bug 708678 - Network Manager catches signal 11 (SIGSEGV) when parsing VPN connection keyfile
Network Manager catches signal 11 (SIGSEGV) when parsing VPN connection keyfile
Status: CLOSED DUPLICATE of bug 708445
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 15:39 EDT by Dan Krejsa
Modified: 2011-05-30 16:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 16:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract from /var/log/messages showing the crash, with backtraces (69.63 KB, application/octet-stream)
2011-05-28 15:39 EDT, Dan Krejsa
no flags Details
The VPN connection file from /etc/NetworkManager/system-connections/ with some sensitive information censored. (392 bytes, application/octet-stream)
2011-05-28 15:42 EDT, Dan Krejsa
no flags Details

  None (edit)
Description Dan Krejsa 2011-05-28 15:39:03 EDT
Created attachment 501519 [details]
Extract from /var/log/messages showing the crash, with backtraces

Description of problem:

Running on Fedora 15 with NetworkManager-0.8.999-3.git20110526.fc15.i686.

After adding a configuration for a Cisco VPN, Network Manager crashes and fails
to start at reboot.  /var/log/messages (relevant part attached, with debuginfo backtraces) shows that Network Manager is getting an exception while
parsing the VPN connection keyfile:

May 28 11:38:55 localhost NetworkManager[766]:    keyfile: parsing VPN connection 1 ... 
May 28 11:38:55 localhost NetworkManager[766]: <warn> caught signal 11. Generating backtrace...
May 28 11:38:55 localhost NetworkManager: ******************* START **********************************

It is necessary to remove the connection file from /etc/NetworkManager/system-connections/ before NetworkManager will successfully start.


Version-Release number of selected component (if applicable):


Running on Fedora 15 with NetworkManager-0.8.999-3.git20110526.fc15.i686.
[dlkrejsa@localhost ~]$ rpm -qa | grep NetworkManager
NetworkManager-glib-0.8.999-3.git20110526.fc15.i686
NetworkManager-pptp-0.8.999-1.fc15.i686
evolution-NetworkManager-3.0.1-1.fc15.i686
NetworkManager-vpnc-0.8.999-2.fc15.i686
NetworkManager-0.8.999-3.git20110526.fc15.i686
NetworkManager-debuginfo-0.8.999-3.git20110526.fc15.i686
NetworkManager-openvpn-0.8.999-1.fc15.i686
NetworkManager-vpnc-debuginfo-0.8.999-2.fc15.i686
NetworkManager-gnome-0.8.999-3.git20110526.fc15.i686
NetworkManager-openconnect-0.8.999-1.fc15.i686


How reproducible:

Very


Steps to Reproduce:
1. In Network System Settings, add a VPN connection (by clicking on the
   plus sign under the existing Wired / Wireless / Network proxy / etc.
   listings -- pet peeve: this is much harder to find than in the older gui),
   selecting 'VPN' from the interface list (it's the only option) and clicing
   Create...
2. Choose 'Cisco Compatible VPN (vpnc)' connection type. Click Create..
3. Enter Cancel VPN settings (where's the option to import from a .pcf file?)
   I entered the Gateway, Group name, and used a 'Saved' Group password,
    no User password, and unchecked 'Available to all users'.  Click Save.

Actual results:

Network Manager crashes and won't restart after reboot or logout.


Expected results:

New VPN configuration should be available for use and Network Manager should
not crash.

Additional info:
Comment 1 Dan Krejsa 2011-05-28 15:42:06 EDT
Created attachment 501520 [details]
The VPN connection file from /etc/NetworkManager/system-connections/ with some sensitive information censored.
Comment 2 HulkDerHungrige 2011-05-28 15:44:25 EDT
It also happens with OpenVPN connections.
Comment 3 Dan Krejsa 2011-05-28 15:48:38 EDT
In step 3, 'Enter Cancel VPN settings' should just be 'Enter VPN settings'.
Comment 4 Danila Migalin 2011-05-29 01:24:30 EDT
Have a same problem with OpenVPN connection

After removing the connection file from /etc/NetworkManager/system-connections, NetworkManager can be restarted and works normal.
Comment 5 Lukas Zapletal 2011-05-30 03:34:57 EDT
I confirm this. I am also unable to recreate the setting again. Getting the same signal again.

http://pastie.org/1991986
Comment 6 Michael Ekstrand 2011-05-30 12:15:21 EDT
Looks to me like this is the same problem as https://bugzilla.redhat.com/show_bug.cgi?id=625047.

This introduces a major regression into Fedora 15 - I had about a half-dozen network configs that had to be moved out of the way before NetworkManager would start after updating.  It doesn't just apply to VPN configs - I am seeing the same with wireless network configurations as well.
Comment 7 Toby Haynes 2011-05-30 13:36:05 EDT
Creating a VPN session with a name _without_ any spaces appears to work - I can't do a full test until I get home. Given that the DEFAULT name is "VPN Connection 1", you must alter this before saving.
Comment 8 Jirka Klimes 2011-05-30 16:12:43 EDT

*** This bug has been marked as a duplicate of bug 708445 ***

Note You need to log in before you can comment on or make changes to this bug.