Bug 708700 - NetworkManager crash when attempting to create pptp connection
NetworkManager crash when attempting to create pptp connection
Status: CLOSED DUPLICATE of bug 708445
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
15
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-28 17:55 EDT by Maurice James
Modified: 2011-05-30 16:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 16:16:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maurice James 2011-05-28 17:55:07 EDT
Description of problem:
When attempting to create a pptp connection NetworkManager fatally crashes and cannot be restarted even after reboot or re-install. Network Manager can only be restarted if the newly created connection is removed through the CLI

Version-Release number of selected component (if applicable):


How reproducible:
Consistent

Steps to Reproduce:
1.Create a new PPTP connection
2.Save the connection
3.
  
Actual results:
You will receive the following error upon clicking "Save"
Message did not receive a reply timeout by message bus

Expected results:
New PPTP VPN connection

Additional info:
I can be reached at midnightsteel@msn.com for more information
Comment 1 Maurice James 2011-05-28 18:01:51 EDT
***UPDATE***

The problems seems to occur when you include a <space> in the VPN connection name. Fedora 14 did not have this problem
Comment 2 Maurice James 2011-05-28 23:44:29 EDT
Logs after crash


May 28 14:39:19 hydra NetworkManager[730]: <warn> caught signal 11. Generating backtrace...
May 28 14:39:19 hydra NetworkManager: ******************* START **********************************
May 28 14:39:20 hydra NetworkManager: [Thread debugging using libthread_db enabled]
May 28 14:39:20 hydra NetworkManager: [New Thread 0xb6effb70 (LWP 1974)]
May 28 14:39:20 hydra NetworkManager: [New Thread 0xb7834b70 (LWP 797)]
May 28 14:39:20 hydra NetworkManager: 0x00a4b424 in __kernel_vsyscall ()
May 28 14:39:20 hydra NetworkManager: #0  0x00a4b424 in __kernel_vsyscall ()
May 28 14:39:20 hydra NetworkManager: #1  0x002cf5cb in waitpid () from /lib/libpthread.so.0
May 28 14:39:20 hydra NetworkManager: #2  0x080a4b65 in nm_logging_backtrace ()
May 28 14:39:20 hydra NetworkManager: #3  0x0808a21d in ?? ()
May 28 14:39:20 hydra NetworkManager: #4  <signal handler called>
May 28 14:39:20 hydra NetworkManager: #5  0x005880d2 in g_hash_table_iter_next () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: #6  0x080d3340 in ?? ()
May 28 14:39:20 hydra NetworkManager: #7  0x080d4fd1 in nm_settings_connection_replace_settings ()
May 28 14:39:20 hydra NetworkManager: #8  0x080def34 in nm_keyfile_connection_new ()
May 28 14:39:20 hydra NetworkManager: #9  0x080db2f2 in ?? ()
May 28 14:39:20 hydra NetworkManager: #10 0x080db3dc in ?? ()
May 28 14:39:20 hydra NetworkManager: #11 0x080d2f5b in nm_system_config_interface_add_connection ()
May 28 14:39:20 hydra NetworkManager: #12 0x080cff7f in ?? ()
May 28 14:39:20 hydra NetworkManager: #13 0x080d0362 in ?? ()
May 28 14:39:20 hydra NetworkManager: #14 0x0809c1be in ?? ()
May 28 14:39:20 hydra NetworkManager: #15 0x0809c308 in ?? ()
May 28 14:39:20 hydra NetworkManager: #16 0x0033ae33 in g_simple_async_result_complete () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: #17 0x00a69de7 in ?? () from /usr/lib/libpolkit-gobject-1.so.0

May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: 
May 28 14:39:20 hydra NetworkManager: Thread 2 (Thread 0xb6effb70 (LWP 1974)):
May 28 14:39:20 hydra NetworkManager: #0  0x00a4b424 in __kernel_vsyscall ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #1  0x002ce6eb in read () from /lib/libpthread.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #2  0x0059b67f in ?? () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #3  0x005c1755 in ?? () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #4  0x002c7c5e in start_thread () from /lib/libpthread.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #5  0x01032b4e in clone () from /lib/libc.so.6
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: 
May 28 14:39:20 hydra NetworkManager: Thread 1 (Thread 0xb7835750 (LWP 730)):
May 28 14:39:20 hydra NetworkManager: #0  0x00a4b424 in __kernel_vsyscall ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #1  0x002cf5cb in waitpid () from /lib/libpthread.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #2  0x080a4b65 in nm_logging_backtrace ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #3  0x0808a21d in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #4  <signal handler called>
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #5  0x005880d2 in g_hash_table_iter_next () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #6  0x080d3340 in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #7  0x080d4fd1 in nm_settings_connection_replace_settings ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #8  0x080def34 in nm_keyfile_connection_new ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #9  0x080db2f2 in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #10 0x080db3dc in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #11 0x080d2f5b in nm_system_config_interface_add_connection ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #12 0x080cff7f in ?? ()

May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #13 0x080d0362 in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #14 0x0809c1be in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #15 0x0809c308 in ?? ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #16 0x0033ae33 in g_simple_async_result_complete () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #17 0x00a69de7 in ?? () from /usr/lib/libpolkit-gobject-1.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #18 0x0033ae33 in g_simple_async_result_complete () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #19 0x00391775 in ?? () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #20 0x0033ae33 in g_simple_async_result_complete () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #21 0x0038668c in ?? () from /lib/libgio-2.0.so.0

May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #22 0x0033ae33 in g_simple_async_result_complete () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #23 0x0033af5c in ?? () from /lib/libgio-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #24 0x00595851 in ?? () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #25 0x005997ff in g_main_context_dispatch () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #26 0x00599f70 in ?? () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #27 0x0059a697 in g_main_loop_run () from /lib/libglib-2.0.so.0
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: #28 0x080617d2 in main ()
May 28 14:39:20 hydra NetworkManager: No symbol table info available.
May 28 14:39:20 hydra NetworkManager: A debugging session is active.
May 28 14:39:20 hydra NetworkManager: 
May 28 14:39:20 hydra NetworkManager: #011Inferior 1 [process 730] will be detached.
May 28 14:39:20 hydra NetworkManager: 
May 28 14:39:20 hydra NetworkManager: Quit anyway? (y or n) [answered Y; input not from terminal]
May 28 14:39:20 hydra NetworkManager: ******************* END **********************************
May 28 14:39:20 hydra systemd[1]: NetworkManager.service: main process exited, code=exited, status=1
May 28 14:39:20 hydra systemd[1]: Unit NetworkManager.service entered failed state.
Comment 3 niowfi 2011-05-29 19:14:50 EDT
I have the same problem while I try to create a vpnc connection.

After this error, network Manager doesn't start after a reboot. I need to erase the /etc/NetworkManager/system-connections/"Network connection name" file to be able to start Network Manager again.

Like Maurice James said, this error only occur when you include a space on the connection name.
Comment 4 Jirka Klimes 2011-05-30 09:13:44 EDT
I can't reproduce that with the latest update:
NetworkManager-0.8.999-3.git20110526.fc15.x86_64
NetworkManager-gnome-0.8.999-3.git20110526.fc15.x86_64

Can you upgrade to it and see if you still have the issue?
Comment 5 Jirka Klimes 2011-05-30 16:15:51 EDT
I couldn't reproduce because it crashes on i686 installs only.
Comment 6 Jirka Klimes 2011-05-30 16:16:07 EDT

*** This bug has been marked as a duplicate of bug 708445 ***

Note You need to log in before you can comment on or make changes to this bug.