Bug 70873 - samba browsing not working
samba browsing not working
Status: CLOSED DUPLICATE of bug 76253
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-vfs2-extras (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-06 08:45 EDT by Miloš Komarčević
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 14:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb session (12.57 KB, text/plain)
2002-08-28 07:17 EDT, Tim Waugh
no flags Details
Another gdb session backtrace while accessing localhost running samba (18.30 KB, text/plain)
2002-09-03 08:55 EDT, Miloš Komarčević
no flags Details

  None (edit)
Description Miloš Komarčević 2002-08-06 08:45:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Nautilus stops responding if I try to browse a computer
with samba shares. The workgroups are browseable and
their computers are shown, but it is not possible to browse
individual machines. The number of folders (shares) is shown
in the side pane and nautilus stops responding.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Type smb: in nautilus location bar
2.Attempt to browse any computer shown
3.
	

Actual Results:  nautilus stops responding

Expected Results:  available shares should be shown in nautilus,
and/or the user should be prompted for username/password

Additional info:
Comment 1 Alexander Larsson 2002-08-09 12:01:34 EDT
It works for me here.
I've built 0.99.2 in rawhide. Can you try that?
Comment 2 Alexander Larsson 2002-08-09 12:06:25 EDT
Well. Hmmm. It seems it can't actually read the files.
Comment 3 Alexander Larsson 2002-08-12 09:49:50 EDT
Reading files now works in gnome-vfs2-extras 0.99.3.
Comment 4 Miloš Komarčević 2002-08-14 20:38:10 EDT
both 0.99.2 nor 0.99.3 didn't get rid of the problem for me completely,
although it started working properly on some of the machines,
but most of them I still cannot access

on a different machine in another workgruop, smb: does not
even bring up the workgroup, although smbclient sees all the 
other machines and says my machine is the local master

maybe a network problem or something on the server side?
gnome1 module didn't have these problems in the same environment
Comment 5 Alexander Larsson 2002-08-20 04:16:27 EDT
Can you see a pattern for which machines it works for? Are they on the same
subnet  as the ones that don't work?

The code hardly changed at all between gnome1 and gnome2, so it's very strange
that they behave differently.
Comment 6 Alexander Larsson 2002-08-27 07:47:52 EDT
When this happens, can you attach to the nautilus process using gdb?
using "gdb /usr/bin/nautilus <pid-of-nautilus>"
Then type:
 info threads
then:
 thread 1
 bt
 thread 2
 bt
etc. for all the threads.

Comment 7 Tim Waugh 2002-08-28 07:17:00 EDT
Created attachment 73504 [details]
gdb session
Comment 8 Alexander Larsson 2002-08-28 07:20:01 EDT
WTH? This looks like bug 71419
Comment 9 Preston Brown 2002-08-28 22:46:56 EDT
0.99.3 works for me against XP shares...
Comment 10 Tim Waugh 2002-08-29 03:02:11 EDT
..and after about three hangs, I couldn't reproduce the problem any more, even 
without having changed anything(!). 
 
Heisenbug.
Comment 11 Miloš Komarčević 2002-09-03 08:55:27 EDT
Created attachment 74685 [details]
Another gdb session backtrace while accessing localhost running samba
Comment 12 Alexander Larsson 2002-09-03 09:23:10 EDT
Interesting. That looks like a real locking bug in the smb backend.
When it hanged. Was there an authetication dialog up somewhere?
If so, can you close it and see if stuff continues.
Comment 13 Alexander Larsson 2002-09-03 10:01:37 EDT
I believe this is fixed in gnome-vfs2-extras-0.99.5-1.
Comment 14 Miloš Komarčević 2002-10-07 14:07:27 EDT
0.99.5 does not hang any more

although I still have a problem seeing the shares:

- on Windows 2000 Server no shares are shown (not even public ones) 
and there is no authentication dialog (smbclient lists all 
the shares correctly)

- on Samba 2.2.5 machines, the "homes" share is not shown (it is as "homes" 
when set to "browseable=yes", but not as "username" as reported by smbclient
when "browseable=no") and is not accessible as smb://server/username
(this behaviour probably makes sense with the setting "browseable=no",
although in windows explorer it is accessible and shows up as share
"username" once authenticated)
what's the right behaviour between the two is up for debate, I think
as a minimum it should be accessible directly as smb://server/username
even if it is not browseable and not shown in the root window

you can close this bug as all of this might be a different bug 
Comment 15 Alexander Larsson 2002-11-06 03:22:55 EST

*** This bug has been marked as a duplicate of 76253 ***

Note You need to log in before you can comment on or make changes to this bug.