Bug 708777 - Using USB hard drive WDBAAA500ASL (My Passport) the O.S. freezes when "Safely remove drive" is selected.
Using USB hard drive WDBAAA500ASL (My Passport) the O.S. freezes when "Safely...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 09:53 EDT by Don Church
Modified: 2011-11-13 13:03 EST (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.40.6-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-05 19:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
info printed to screen at system lockup kernel 2.6.40-x (i686) (351.35 KB, image/jpeg)
2011-09-26 21:46 EDT, Don Church
no flags Details

  None (edit)
Description Don Church 2011-05-29 09:53:11 EDT
Description of problem:

After a second of two of selecting "Safely remove drive", F15 freezes requiring the us of the reset button or power off on both my older ICH9R desktop and my new Asus EEE netbook.  Everything seems to work fine until then.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.

After connected, from file manager UI, right click and select "Safely remove drive"

2.
3.
  
Actual results:

Complete system freeze.  No response to ctrl-alt-del,bkspc,or f1(f2,ect)


Expected results:


Additional info:
Comment 1 Jiri Moskovcak 2011-05-30 04:39:08 EDT
Seem more like a kernel problem -> reassigning.
Comment 2 Josh Boyer 2011-09-26 13:43:39 EDT
There was a fix for an issue that sounds similar to this in one of the recent 2.6.40.x F15 kernels.  Does the latest F15 kernel have this issue?
Comment 3 Don Church 2011-09-26 21:46:36 EDT
Created attachment 525023 [details]
info printed to screen at system lockup kernel 2.6.40-x (i686)

The same problem currently exists with my 32bit F15 system only this time the display dropped to the console before freezing so here's the picture I took.
Comment 4 Josh Boyer 2011-10-04 10:32:47 EDT
Could you please try this update and see if the problems recreate:

https://admin.fedoraproject.org/updates/kernel-2.6.40.6-0.fc15

We've added another possible fix for this issue from upstream.
Comment 5 Don Church 2011-10-04 20:46:15 EDT
Alrighty...I installed the PAE kernel i686 and things work well.

No freeze or crash, the only thing is that I have to select safely remove device two times since the first time I get a failure to unmount notice due to a busy file system or device but that happens occasionally on other usb storage occasionally.

Good work and thanks much.
Comment 6 Josh Boyer 2011-10-05 07:43:51 EDT
Thank you for confirming.  I'll edit the update to include this bug.
Comment 7 Fedora Update System 2011-10-05 07:45:51 EDT
kernel-2.6.40.6-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/FEDORA-2011-13809
Comment 8 Fedora Update System 2011-10-05 19:59:02 EDT
kernel-2.6.40.6-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.