Bug 70882 - Problem with Video Card: Cirrus Logic 54XX series
Problem with Video Card: Cirrus Logic 54XX series
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 10:54 EDT by presciniti
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 04:03:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description presciniti 2002-08-06 10:54:39 EDT
Description of Problem:
When I try to bring up the XServer system, I can see graphics OK but I cannot 
read any text which makes my system unusable. I had no problems with RedHat 
6.2. Normally, software upgrades try not to take away any capabilities of 
previous versions since it puts customers in a bad position.

Need to get fix for my problem to use the system

Version-Release number of selected component (if applicable):

Red-Hat Professional Version 7.3

How Reproducible:

I have been on the RedHat message boards and several people have had similar 
problems with the GUI as I have (although they have had different cards).

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Mike A. Harris 2002-08-07 03:48:58 EDT
Red Hat does not have every piece of video hardware ever made, nor
the technical specifications for all that hardware, and as such is
unable to test every piece of hardware with every possible motherboard
out there.  Upstream XFree86 releases get updated into the distribution,
once released, and go through a full Red Hat Linux development cycle.
During that cycle, everyone at Red Hat tests the video hardware they
have available on the machines they have available.  This does not
provide adequate coverage for every piece of hardware out there, which
is why Red Hat provides Red Hat "rawhide" - an ongoing release of
our current development packages for users to test and provide bug
reports on problems they encounter.

We also do private beta testing, and also do public beta testing of at
least 2 public beta releases.  Bugs reported during all of this internal
and public testing we try to fix as best we can.  We are not able 
however to fix every bug that is reported, and we are also unable
to test every piece of hardware as I mentioned above.

If we are unaware of a problem, then we are also unable to fix it
prior to release, which is why it is important for users to test our
beta releases early, and report bugs to us.  Users should also report
bugs to XFree86.org directly, since it is ultimately their software
we are shipping.

When a new XFree86 release comes out, we have no idea what code may
have changed in the new release and what hardware that may have worked
fine before that doesn't work properly anymore.

Ultimately - if we do not receive bug reports, we can't fix problems
that occur until we know about them.  Once we do know about problems,
we can and do try to fix as many of these problems as possible, obviously
with priority given to the most widely used hardware.

Sometimes we are unable to debug/troubleshoot video hardware problems
that are reported simply because we do not have the hardware that the
user is reporting as not working (which is also why it is best to
report XFree86 bugs both here, and to xpert@xfree86.org and
xfree86@xfree86.org), and/or we do not have the video hardware technical
specifications for a given card.

I've got a few Cirrus Logic cards, and I have tested those cards.  They
work just fine for me.  If you've got a card that does not work, then
that is a new problem that was unknown until now, so it would have been
impossible to have it work for you in any case out of the box.

Anyway, in order to even begin to troubleshoot this problem, I will
need a copy of your X server log file, and your X config file.  I'll
also need the output of "lspci -vvn" and "lspci -vv"  (both of them).

Also provide "uname -a".

Once I have those details, I can help troubleshoot debug the problem.

If we only shipped drivers we knew worked and worked well, are able
to test, and usually able to fix bugs on, we probably would only
support ATI Radeon, ATI Rage 128, ATI Mach64, Matrox, and 3Dfx
hardware.

Comment 2 Mike A. Harris 2002-08-07 04:03:44 EDT
You can attach the requested files using the bugzilla file attachment link
below.  Forgot to mention that...
Comment 3 Mike A. Harris 2002-09-08 13:34:58 EDT
It's been over a month with no update provided in this report.  I
can't troubleshoot a bug without data to troubleshoot with.  Please
reopen the bug report if it is still important to you and provide
the requested information.

Closing bug WORKSFORME, since I've tested XFree86 4.2.0-8 out with
a 5446 card and it works fine for me.

Note You need to log in before you can comment on or make changes to this bug.