This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 708868 - [abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 0000036c: TAINTED Warning Issued
[abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 00000...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:67dcfe75e648d2896d678bda5e0...
:
: 712577 712830 719697 719726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 19:30 EDT by Juhani Viheräkoski
Modified: 2011-08-17 22:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-2.6.40.3-0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 21:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juhani Viheräkoski 2011-05-29 19:30:05 EDT
abrt version: 2.0.1
architecture:   i686
cmdline:        ro root=UUID=22e4bc47-cff7-4f54-b817-21a0c074037c rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=fi-latin1 rhgb quiet
comment:        This OOPS occurs when using the machine in a normal way or letting it idle (while logged in). There are no specific steps to reproduce this problem, other than keeping a computer turned on (generally) for 2-3 hours.
component:      kernel
kernel:         2.6.38.6-27.fc15.i686 #1 Hewlett-Packard HP dx2000 MT(PL095ET
kernel_tainted: 640
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000036c
reported_to:    kerneloops: URL=http://submit.kerneloops.org/submitoops.php
time:           Mon May 30 01:34:34 2011

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000036c
:IP: [<c0681144>] scsi_prep_state_check+0xc/0x7a
:*pde = 00000000 
:Oops: 0000 [#1] SMP 
:last sysfs file: /sys/devices/pci0000:00/0000:00:1d.2/usb4/idVendor
:Modules linked in: ppp_deflate zlib_deflate ppp_async crc_ccitt ppp_generic slhc fuse 8021q garp stp llc p4_clockmod ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables snd_intel8x0 snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm ppdev option usb_wwan microcode parport_pc usbserial parport snd_timer e100 snd iTCO_wdt soundcore mii i2c_i801 iTCO_vendor_support snd_page_alloc ipv6 uas usb_storage i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: mperf]
:Pid: 1074, comm: udisks-daemon Tainted: G        W   2.6.38.6-27.fc15.i686 #1 Hewlett-Packard HP dx2000 MT(PL095ET)/08FCh
:EIP: 0060:[<c0681144>] EFLAGS: 00010096 CPU: 0
:EIP is at scsi_prep_state_check+0xc/0x7a
:EAX: 00000000 EBX: f137c1d0 ECX: c0681af8 EDX: f137c1d0
:ESI: f686ed60 EDI: 00000000 EBP: f0b6bcc4 ESP: f0b6bcb4
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process udisks-daemon (pid: 1074, ti=f0b6a000 task=f0aa7110 task.ti=f0b6a000)
:Stack:
: 0000001a 00000004 205b621d f137c1d0 f0b6bcd8 c0681a2a f137c1d0 f686ed60
: 00000000 f0b6bcec c0681b1f f137c1d0 f686ed60 f686ed60 f0b6bd10 c05b9f10
: 00000000 f137c1d0 f686ed60 f686f060 00000000 f137c1d0 f686ed60 f0b6bd44
:Call Trace:
: [<c0681a2a>] scsi_setup_blk_pc_cmnd+0x14/0xe2
: [<c0681b1f>] scsi_prep_fn+0x27/0x37
: [<c05b9f10>] blk_peek_request+0xbd/0x17e
: [<c0681369>] scsi_request_fn+0x36/0x3b0
: [<c07d62b3>] ? _raw_spin_unlock_irqrestore+0x13/0x15
: [<c0444cd5>] ? del_timer+0x59/0x61
: [<c05b9b11>] __generic_unplug_device+0x30/0x33
: [<c05bc5de>] blk_execute_rq_nowait+0x65/0x84
: [<c05bc689>] blk_execute_rq+0x8c/0xbf
: [<c05bc54c>] ? blk_end_sync_rq+0x0/0x2d
: [<c05b9300>] ? get_request+0x216/0x21c
: [<c05b9b3f>] ? get_request_wait+0x2b/0x132
: [<c042e4e2>] ? __might_sleep+0x29/0xe4
: [<c05b9c80>] ? blk_get_request+0x3a/0x63
: [<c06805b9>] scsi_execute+0xcb/0x110
: [<c0680632>] ? scsi_execute_req+0x34/0xad
: [<c0680683>] scsi_execute_req+0x85/0xad
: [<c067cd7f>] ioctl_internal_command.constprop.1+0x6f/0x15f
: [<c067cebf>] scsi_set_medium_removal+0x50/0x87
: [<c04e0000>] ? mem_cgroup_print_oom_info+0x83/0x15a
: [<c068de47>] sr_lock_door+0x1b/0x1d
: [<c06ac93d>] cdrom_release+0x180/0x1e2
: [<c05ca846>] ? kobject_put+0x46/0x4c
: [<c042e4e2>] ? __might_sleep+0x29/0xe4
: [<c042e4e2>] ? __might_sleep+0x29/0xe4
: [<c042800f>] ? should_resched+0xd/0x27
: [<c07d5029>] ? _cond_resched+0xd/0x21
: [<c068cf3e>] sr_block_release+0x28/0x3f
: [<c0507ca0>] __blkdev_put+0xa7/0x135
: [<c0507e10>] blkdev_put+0xe2/0xe7
: [<c0507e32>] blkdev_close+0x1d/0x1f
: [<c04e59ba>] fput+0x100/0x183
: [<c04e317b>] filp_close+0x56/0x5e
: [<c04e31e2>] sys_close+0x5f/0x93
: [<c07d66b4>] syscall_call+0x7/0xb
: [<c07d0000>] ? audit_free_context+0x2/0xc3
:Code: b9 27 04 68 c0 31 d2 e8 20 9f ff ff eb 0e b9 a4 10 68 c0 31 d2 89 d8 e8 04 9c fe ff 5b 5d c3 55 89 e5 53 83 ec 0c 3e 8d 74 26 00 <8b> 98 6c 03 00 00 89 c1 31 c0 83 fb 02 74 59 8d 43 fc 83 f8 04 

event_log:
:2011-05-30-02:24:28> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-05-30-02:24:37  Kernel oops report was uploaded
:2011-05-30-02:29:04> Logging into Bugzilla at https://bugzilla.redhat.com
:2011-05-30-02:29:09  Can't login. Server said: RPC failed at server.  The username or password you entered is not valid.
:2011-05-30-02:29:09* (exited with 1)
Comment 1 Juhani Viheräkoski 2011-05-29 19:35:06 EDT
I have no idea about the tainted warning, this kernel is a standard Fedora 15 one and there are no proprietary modules loaded or installed in the system. Therefore my kernel should not be tainted, unless it is caused by some driver in the standard installation, which I suspect is not the case.
Comment 2 Juhani Viheräkoski 2011-05-30 21:53:58 EDT
I checked out and my tainted flag was 128, meaning "System died" according to the kernel documentation. Right now in my running system (still with the same kernel) /proc/sys/kernel/tainted is 0. I was under impression kernel was only tainted by loading proprietary modules, so please ignore my previous comment and sorry for the noise :)
Comment 3 Chuck Ebbert 2011-06-23 08:43:51 EDT
*** Bug 712577 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2011-07-11 15:36:49 EDT
*** Bug 712830 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2011-07-11 15:37:18 EDT
Please test this build.
http://koji.fedoraproject.org/koji/buildinfo?buildID=251810
Comment 6 Dave Jones 2011-07-11 15:39:54 EDT
*** Bug 719697 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2011-07-11 15:40:07 EDT
*** Bug 719726 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2011-07-29 11:54:26 EDT
This bug should be fixed with 2.6.40-3 and higher (available in updates-testing. Please try that kernel, and leave feedback.

Thanks.
Comment 9 Fedora Update System 2011-07-29 12:00:24 EDT
kernel-2.6.40-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-3.fc15
Comment 10 Fedora Update System 2011-07-29 16:39:43 EDT
kernel-2.6.40-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
Comment 11 Fedora Update System 2011-07-30 23:32:53 EDT
Package kernel-2.6.40-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.40-4.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.40-4.fc15
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-08-01 21:57:31 EDT
kernel-2.6.40-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-08-16 08:47:46 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 14 Fedora Update System 2011-08-17 22:30:35 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.