Bug 7089 - install hangs after 'linux updates' on ThinkPad 770Z
install hangs after 'linux updates' on ThinkPad 770Z
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-17 18:01 EST by Landon Curt Noll
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 12:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 1999-11-17 18:01:56 EST
When I with the boot-RHEA-1999_044.img image (because the RH6.1 shipped
one does not work for ThinkPads).  I then insert the RH6.1 CD and type:

	linux updates

at the LILO.  The kernel boots and makes it up to printing:

	running /sbin/loader

It then accesses the CDROM for a bit and hangs.

I am running on a ThinkPad 770Z.
Comment 1 Anonymous 1999-11-17 19:18:59 EST
Interestingly enough, if do not have the RH6.1 CDROM inserted when I
enter 'linux updates' the installation process get farther along.

For example if I wait until the ``Installation Method'' screen, insert
the CDROM and select local CDROM, I am able to continue.  But all is
not well because when it asks me to ``Insert your updates disk''
(where I insert the a floppy with updates-RHEA-1999_045.img), it
reads the anaconda updates, accesses the CDROM, attempts to start up
and X server and hangs ...

It does identify the cyber9397dvd chipset, tries to setup on a 640x480
mode, but fails with a:

  error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy

and the X server hangs.

So the install (booted via linux updates) hangs early on if the CDROM is
inserted AFTER the boot disk is read (no, I am not booting off of the CDROM)
and before the 'linux updates' is entered.  However if you delay the CDROM
insertion until after the installers gets going, you hang in the X server.
Comment 2 Anonymous 1999-11-18 19:14:59 EST
If I withhold the CDROM, boot from the boot-RHEA-1999_044.img image and type:

	linux updates text

insert the CDROM near the ``Installation Method'' screen, insert the
updates-RHEA-1999_045.img updates disk when requested, the installer
avoids the X server hang up runs into another problem.

When I select ``Upgrade Existing Installation'' it says:

    You don't have any Linux partitions.  You can't upgrade this system!

On my disk I have:

	P 1	hda1	ext2	/boot
	P 2	hda2	FAT32	/c
	P 3	extended
	E 5	hda5	swap
	E 6	hda6	ext2	/var/tmp
	E 7	hda7	ext2	/var
	E 8	hda8	ext2	/home
	E 9	hda9	ext2	/tmp
	E10	hda10	ext2	/
	E11	hda11	ext2	/usr/local
Comment 3 Brad Lauster 1999-11-22 14:33:59 EST
I have seen this behavior on the IBM ThinkPad 600e as well.
It stalls at:
   running /sbin/loader

I have also been able to get the installation process further along by not
inserting the RH 6.1 CD until absolutely necessary...
I've never gotten past just after the updates (updates-RHEA-1999_045.img) disk
is read.
Comment 4 Jay Turner 1999-11-29 13:59:59 EST
The hang during an update if the cdrom is in the drive is a known problem for
which we will be releasing an update here in the near future.  The hang on the
ThinkPads after reading the updates disk is a new one on me.  I will check
around and see if I am able to replicate this in the lab.

As for the system telling you that it cannot find a linux installation to
upgrade, I am betting that the extended partition that you have is type "f"  If
this is the case, then we have found the problem.  There is a known bug in the
installer which prevents it from seeing past a type "f" partition.  There are a
couple of ways to take care of this.  One, you can wait until we get the next
updates disk out which will fix this problem.  Or you can convert the extended
partition from type "f" to type "5" which will allow you to perform the upgrade
without any problems.  After finishing the upgrade, you can convert the
partition back to type "f".

Note You need to log in before you can comment on or make changes to this bug.