Bug 70891 - Limbo: Installer hangs after loading disc 2
Limbo: Installer hangs after loading disc 2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 12:55 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 17:27:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-06 12:55:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Win95; U)

Description of problem:
I am installing Limbo Beta per instructions for fixing Trident video bugs in Linux 7.3.  I downloaded all 5 disc images, verified them (all report good). 
 Disc one boots and begins the install.  When the system asks for Disc 2, I put the disc in and hit OK.  Nothing appears to happen (install stays at 
30%).  After a very long time (overnight) I finally got the message listed below.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start Limbo install (using text mode)
2.Run though to insert of disc 2
3.Insert disc 2 and press ok.
	

Actual Results:  System hung for several hours, then gave error message described below

Expected Results:  System should have installed.

Additional info:

Traceback (most recent call last):
   File "/usr/bin/anaconda", Line 601, in ?
       intf.run(id, dispatch, configFileData)
   File "/usr/lib/anaconda/text.py", Line 443, in run
       dispatch.gotoNext()
   File "/usr/lib/anaconda/dispatch.py", Line 150, in gotoNext
       self.moveStep()
   File "/usr/lib/anaconda/dispatch.py", Line 215, in moveStep
       rc = apply(func, self.bindArgs(args))
   File "/usr/lib/anaconda/packages.py", line 668, in doInstall
       problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
   File "/usr/lib/anaconda/packages.py", Line 280, in cb
       fn = self.method.getFilename(h, self.pkgTimer)
   File "/usr/lib/anaconda/image.py", line 209, in getFilename
       errnum, h[1000000], str(msg))
   File "/usr/lib/python2.2/site-packages/rhpl/log.py", line 24, in __call__
       self.handler(format % args)
   File "/usr/lib/anaconda/anaconda-log.py", line 60, in __call__
       self.logFile 2.flush()
   IOError: [Errno 28] No space left on device



I have a 4GB hard disk on this system.  Linux 7.3, 7.2 and 7.1 did not complain about no disk space left
Comment 1 Michael Fulbright 2002-08-12 14:44:09 EDT
Just to verify - were you doing an install or an upgrade?

Were you given the option to save this error log to a floppy?

How much RAM do you have?

What size partitions/filesystems did you configure?
Comment 2 Need Real Name 2002-08-12 15:01:18 EDT
I have tried both upgrade and full install.  Both hang at the same point.  I don't remember if it gave the option or not to save to floppy, it might have.

I let the installer auto partition the drive.  I have 128M of RAM.
Comment 3 Michael Fulbright 2002-08-13 11:48:06 EDT
Could you try this:

Install from disc 1.

When it prompts for disc 2, don't put in the disc.

Instead hit cntl-alt-F2 and you should see a command prompt.

Type 'df'

If you could write down the output and add it to this report that would really help.

Comment 4 Need Real Name 2002-08-13 14:17:27 EDT
Filesystem                 1KBlocks              used             available              used%            mounted on
rootfs                             3495                    821                  2474                    25%                    /
/dev/root.old                  3495                   821                   2474                   25%                    /
/tmp/hda5                 505605                 130208           349293                  27%                   /mnt/sysimage
/tmp/hda1                 101089                  12057             83813                    13%                  /mnt/sysimage/boot
/tmp/hda3                  1731460               32828              1610680                2%                  /mnt/sysimage/home
/tmp/hda2                 4727888              1125864           3361856               25%                /mnt/sysimage/usr
/tmp/hda6                 1027760                48292              927268                 5%                   /mnt/sysimage/var
Comment 5 Michael Fulbright 2002-08-14 13:01:41 EDT
Could you try running the same commands above after the you've inserted CD#2 and
the system has appeared to hang?

I'm thinking something created alot of log messages in relation to the second
CD, filling up the tmp space (which has lots of room in the output you appended
above).
Comment 6 Need Real Name 2002-08-15 09:54:45 EDT
Here is the information after the failure message:


Filesystem                 1KBlocks              used             available              used%            mounted on
 rootfs                             3495                    3495                 0                        100%                    /
 /dev/root.old                  3495                   3495                   0                        100%                    /
 /tmp/hda5                 505605                 130208           349293                  27%                   /mnt/sysimage
 /tmp/hda1                 101089                  12057             83813                    13%                  /mnt/sysimage/boot
 /tmp/hda3                  1731460               32828              1610680                2%                  /mnt/sysimage/home
 /tmp/hda2                 4727888              1125864           3361856               25%                /mnt/sysimage/usr
 /tmp/hda6                 1027760                48292              927268                 5%                   /mnt/sysimage/var
/tmp/hdc                     667168                 667168                 0                       100%              /mnt/source
Comment 7 Michael Fulbright 2002-08-15 12:50:03 EDT
Excellent, see:

 rootfs    3495     3495        0       100%        /

Its full.

So now to figure out why.

When the computer is in this state, do a:

ls -l /tmp

Find out which file is the biggest, then do a 

less <filename>

Hold down 'Page Down' and scroll to the bottom of the file and let me know what
kind of messages you see down there.

Thanks for being patient and trying all these steps. I've never seen this happen
before!
Comment 8 Need Real Name 2002-08-15 13:00:48 EDT
I have pages and pages of:

<6> attempt to access beyond end of device
<6> 16:00: rw=0, want = 405546, limit = 197120

in file /tmp/syslog  size 1926028
Comment 9 Michael Fulbright 2002-08-19 12:52:38 EDT
What type of CDROM drive do you have (IDE, SCSI, other)?

The device 16:00 is a Goldstar CDROM device, which seems odd.
Comment 10 Need Real Name 2002-08-19 14:03:55 EDT
It is an IDE drive on channel 2 with the hard drive on channel 1.
Comment 11 Michael Fulbright 2002-08-23 12:10:33 EDT
Could you try perhaps putting the ISO images on your hard drive and doing a hard
drive install? It appears the CD drive and the CD #2 you have are not working
well togethre, since its generating all those error messages.
Comment 12 Need Real Name 2002-08-26 15:19:27 EDT
Hard drive install does not work correctly.  It will not allow me to properly select the options (ie. Install Beta button.)  It keeps going into a reboot 
selection and I cannot proceed.  Why would the Beta have problems with my cdrom drive and 7.1, 7.2 and 7.3 installs don't?
Comment 13 Need Real Name 2002-08-26 17:27:18 EDT
After playing around for some time, I did get the install to start.  After a few minutes, I get the following error:

The File
/tmp/isomedia/RedHat/RPMS/omni-0.7.0-4.i386.rpm cannot be opened.
This is due to a missing file, a bad package, or bad media.  Press <return> to try again.


and the install stops there.  I checked my cd media and they all check fine and I am using the same ISO files that made the cd's.
Comment 14 Michael Fulbright 2002-09-20 17:19:48 EDT
CD media and CD drives can interact in strange ways.  If you can try a different
CD drive that might help.
Comment 15 Need Real Name 2002-09-25 13:16:14 EDT
I tried a different CD drive and I tried the hard drive install again. Both setups got to the same point as above and failed.

Note You need to log in before you can comment on or make changes to this bug.