Bug 708927 - Qemu-KVM always starting VM with core2duo processor
Qemu-KVM always starting VM with core2duo processor
Status: CLOSED DUPLICATE of bug 804224
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-30 03:35 EDT by Vincent passaro
Modified: 2013-01-09 18:54 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 10:52:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vincent passaro 2011-05-30 03:35:36 EDT
Description of problem: Configured Windows7 virtual machine with Westmere CPU in Virtual Machine Manager, but ps + iotop shows qemu always using the core2duo setting.

Version-Release number of selected component (if applicable):

qemu-kvm-0.14.0-7.fc15.x86_64

How reproducible:  ALWAYS


Steps to Reproduce:
1. Create Virtual Machine
2. Set CPU to Westmere (or other)
3. Run virtual machine
4. ps -ef | grep -i qemu
5. qemu-kvm shows cpu as core2duo instead of Westmere.
  
Actual results:  core2duo as qemu-kvm flag


Expected results:  Westmere as qemu-kvm flag


Additional info:

Output from PS:

qemu     19566     1 25 00:03 ?        00:05:02 /usr/bin/qemu-kvm -S -M pc-0.14 -cpu core2duo

Output from /etc/libvirt/qemu/Windoz7.xml

<cpu match='exact'>
    <model>Westmere</model>
    <vendor>Intel</vendor>
    <feature policy='require' name='tm2'/>
    <feature policy='require' name='est'/>
    <feature policy='require' name='monitor'/>
    <feature policy='require' name='ss'/>
    <feature policy='require' name='vme'/>
    <feature policy='require' name='rdtscp'/>
    <feature policy='require' name='ht'/>
    <feature policy='require' name='ds'/>
    <feature policy='require' name='pbe'/>
    <feature policy='require' name='tm'/>
    <feature policy='require' name='vmx'/>
    <feature policy='require' name='ds_cpl'/>
    <feature policy='require' name='xtpr'/>
    <feature policy='require' name='acpi'/>
  </cpu>
Comment 1 Vincent passaro 2011-05-30 03:59:18 EDT
Also verified that RHEL 6 guest gets core2duo CPU when Westmere is selected.
Comment 2 Jarkko Torvinen 2011-05-30 04:27:57 EDT
I can also verify this. I have a i7 cpu and if I "copy host cpu configuration" it sets it to "Westmere" but when running ps shows -cpu core2duo

If I run qemu-kvm with -cpu Westmere I get an error message:
Unable to find x86 CPU definition
Comment 3 Justin M. Forbes 2011-06-22 10:05:35 EDT
Westmere is not a defined -cpu in qemu for F15.  Available options for -cpu can be seen with qemu -cpu ?:

x86           [n270]
x86         [athlon]
x86       [pentium3]
x86       [pentium2]
x86        [pentium]
x86            [486]
x86        [coreduo]
x86          [kvm32]
x86         [qemu32]
x86          [kvm64]
x86       [core2duo]
x86         [phenom]
x86         [qemu64]

Though perhaps libvirt shouldn't try to set unsupported -cpu flags.
Comment 4 Vincent passaro 2011-12-08 15:14:55 EST
This is still happening in Fedora 16
Comment 5 Fedora Admin XMLRPC Client 2012-03-15 13:53:09 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Martin Kletzander 2012-03-19 10:52:38 EDT

*** This bug has been marked as a duplicate of bug 804224 ***

Note You need to log in before you can comment on or make changes to this bug.