Bug 708933 - AttributeError: 'NoneType' object has no attribute 'rfind'
AttributeError: 'NoneType' object has no attribute 'rfind'
Status: CLOSED DUPLICATE of bug 706542
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:09bb15855e2314432...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-30 04:05 EDT by Ricky Zhou
Modified: 2011-05-30 04:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 04:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (290.19 KB, text/plain)
2011-05-30 04:05 EDT, Ricky Zhou
no flags Details

  None (edit)
Description Ricky Zhou 2011-05-30 04:05:15 EDT
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/posixpath.py", line 112, in basename
    i = p.rfind('/') + 1
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 422, in majorminor
    device = dm_node_from_name(os.path.basename(self.device))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 271, in cacheMajorminor
    self.majorminor # this does the caching
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 700, in _preTeardown
    self.format.cacheMajorminor()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 714, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1868, in teardownAll
    device.teardown(recursive=True)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 103, in turnOnFilesystems
    anaconda.storage.devicetree.teardownAll()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 234, in currentStep
    self.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1290, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1476, in setup_window
    self.setScreen()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1490, in run
    self.setup_window(False)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1221, in run
    self.icw.run()
  File "/usr/sbin/anaconda", line 925, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 Ricky Zhou 2011-05-30 04:05:20 EDT
Created attachment 501738 [details]
Attached traceback automatically from anaconda.
Comment 2 Ricky Zhou 2011-05-30 04:08:56 EDT
Oops, didn't check existing bugs first, looks like this is a duplicate of #706542.

*** This bug has been marked as a duplicate of bug 706542 ***

Note You need to log in before you can comment on or make changes to this bug.