Bug 70906 - traceback on save and exit
traceback on save and exit
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-bind (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-06 15:33 EDT by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 11:05:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-08-06 15:33:41 EDT
If I open the app, select Quit, and select Save and Exit, I get this:

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-bind-gui", line 384, in on_exit_activate
    on_apply_and_save_activate()
  File "/usr/sbin/redhat-config-bind-gui", line 330, in on_apply_and_save_activate
    on_apply_activate()
  File "/usr/sbin/redhat-config-bind-gui", line 324, in on_apply_activate
    cfg.saveBind()
  File "/usr/share/redhat-config-bind/dnsdata.py", line 566, in saveBind
    self.zone_box.write(self.ctx)
  File "/usr/lib/python2.2/site-packages/ForgeBlackBox.py", line 101, in write
    fd = os.open(match.group("filename"), os.O_WRONLY | os.O_CREAT | os.O_TRUNC,
self.mode)
OSError: [Errno 13] Permission denied: '/var/named/0.0.127.in-addr.arpa.zone'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-bind-gui", line 391, in on_bindconf_delete_event
    on_exit_activate(args)
  File "/usr/sbin/redhat-config-bind-gui", line 381, in on_exit_activate
    dialog.set_transient_for (xml.get_widget ('bindconf'))
AttributeError: 'NoneType' object has no attribute 'set_transient_for'
Comment 1 Daniel Walsh 2002-08-07 11:05:09 EDT
This was caused by a prior bad version of redhat-config-bind that set ownership of
its files to root instead of named.named.   Change the ownership to named.named
and run with 1.7.1-9 or newer.
Comment 2 Jay Turner 2002-08-09 09:06:24 EDT
No longer seeing this problem with redhat-config-bind-1.7.1-12.

Note You need to log in before you can comment on or make changes to this bug.