Bug 70916 - Installer hangs after running up2date
Summary: Installer hangs after running up2date
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-06 20:54 UTC by Matt Jamison
Modified: 2007-07-31 19:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-08-08 19:42:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Josef Komenda 2002-08-06 20:54:00 UTC
Description of Problem: Latest build of installer: 
    http://zealot.devel.redhat.com/installer/installer.iso 
hangs after running up2date. 

Ctrl-c in console window breaks the up2date death grip and return you to the
installer, but that causes an error (did not register correctly). You end up
having to delete the server, go back to the register screen, and run it again.
(the 2nd time, up2date finds everythiung updated already and passes on by cleanly)

Version-Release number of selected component (if applicable): see bug 63780

How Reproducible: latest install was on sat-inst.webdev-colo.redhat.com

Comment 1 Adrian Likins 2002-08-08 18:54:01 UTC
more details please...

does up2date finish?

what version of up2date?

any error messages from up2date?

does up2date itself freeze, or just the 
installer when up2date is finished?

What happens when you run up2date by hand seperately
on this box?

what is "up2date death grip"?

Comment 2 Josef Komenda 2002-08-08 19:02:11 UTC
Up2date does finish.
Version: up2date-2.7.61-7.x.2
No error messages that I can find. (looked in /var/log/satinstall)
It looks like the installer is frozen after up2date finishes.
Not sure what happens when I run up2date seperately... will test that now.

The 'death grip' is a reference to the locked up state of the installer. It
unlocks after 2 Ctrl-c's in the console window. 


Comment 3 Adrian Likins 2002-08-08 19:18:52 UTC
can you check to see what /var/lib/rpm looks like
after up2date exists?


any __db* splat files?

Comment 4 Josef Komenda 2002-08-08 19:41:55 UTC
This is after a kickstart and running *just* up2date. It ran just fine. I'll run
the installer again after another kickstart to see if it's the same.

[root@sat-inst root]# ls -l /var/lib/rpm
total 11448
-rw-r--r--    1 rpm      rpm       2732032 Aug  8 15:37 Basenames
-rw-r--r--    1 rpm      rpm         12288 Aug  8 15:37 Conflictname
-rw-r--r--    1 rpm      rpm        319488 Aug  8 11:09 Dirnames
-rw-r--r--    1 rpm      rpm         12288 Aug  8 15:37 Group
-rw-r--r--    1 rpm      rpm         12288 Aug  8 11:09 Installtid
-rw-r--r--    1 rpm      rpm         24576 Aug  8 15:37 Name
-rw-r--r--    1 rpm      rpm       9007104 Aug  8 15:37 Packages
-rw-r--r--    1 rpm      rpm         94208 Aug  8 15:37 Providename
-rw-r--r--    1 rpm      rpm         36864 Aug  8 11:09 Provideversion
-rw-r--r--    1 rpm      rpm        110592 Aug  8 15:37 Requirename
-rw-r--r--    1 rpm      rpm         69632 Aug  8 11:09 Requireversion
-rw-r--r--    1 rpm      rpm         12288 Aug  8 15:37 Triggername


[root@sat-inst root]# up2date
Migrating network settings from rhn_register
warning: /etc/rndc.conf created as /etc/rndc.conf.rpmnew
/var/tmp/rpm-tmp.15430: [: /var/tmp/rpm-tmp.15430: integer expression expected
warning: /etc/sysconfig/rhn/up2date created as
/etc/sysconfig/rhn/up2date.rpmnew
You have mail in /var/spool/mail/root



Comment 5 Josef Komenda 2002-08-08 22:07:53 UTC
OK, this is also the result of a messed up kickstart file. Grrrr....


Note You need to log in before you can comment on or make changes to this bug.